Bug 242444 - European pkg mirror down
Summary: European pkg mirror down
Status: Closed FIXED
Alias: None
Product: Services
Classification: Unclassified
Component: FTP/WWW Sites & Mirrors (show other bugs)
Version: unspecified
Hardware: Any Any
: --- Affects Only Me
Assignee: FreeBSD Mirror Admin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-05 09:12 UTC by Goran Mekić
Modified: 2019-12-11 11:37 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Goran Mekić 2019-12-05 09:12:53 UTC
I can't reach pkg0.bme.freebsd.org. I used that mirror in my /etc/pkg/FreeBSD.conf as pkg.freebsd.org always resolved to pkg0.nyi.freebsd.org (should it be geo aware?).
Comment 1 Li-Wen Hsu freebsd_committer 2019-12-06 18:59:20 UTC
There is a hardware issue and it's currently taken out of GeoDNS rotation.
Comment 2 Goran Mekić 2019-12-06 20:30:58 UTC
As I'm in Europe (but not EU) and for me pkg.freebsd.org never resolved to European mirror, once the hardware is repaired, I'd like to help with the feedback to configure GeoDNS so we (in this case Serbia) resolve pkg.freebsd.org to BME mirror.
Comment 3 Goran Mekić 2019-12-11 10:32:53 UTC
The BME mirror is back online, but this is still my drill output


# drill pkg.freebsd.org
;; ->>HEADER<<- opcode: QUERY, rcode: NOERROR, id: 16767
;; flags: qr rd ra ; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0 
;; QUESTION SECTION:
;; pkg.freebsd.org.	IN	A

;; ANSWER SECTION:
pkg.freebsd.org.	240	IN	CNAME	pkgmir.geo.freebsd.org.
pkgmir.geo.freebsd.org.	76	IN	A	96.47.72.71


# drill -x 96.47.72.71
;; ->>HEADER<<- opcode: QUERY, rcode: NOERROR, id: 62465
;; flags: qr rd ra ; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0 
;; QUESTION SECTION:
;; 71.72.47.96.in-addr.arpa.	IN	PTR

;; ANSWER SECTION:
71.72.47.96.in-addr.arpa.	3600	IN	PTR	pkg0.nyi.freebsd.org.


Checking on https://www.maxmind.com/en/geoip-demo my IP address is geographically right. They published Python library which is available in ports as net/py-GeoIP2, so there's some GeoIP info about Serbia. The question is how to incorporate that info into FreeBSD GeoDNS infrastructure? I would be more than glad to export data from GeoIP2 in any format.
Comment 4 Li-Wen Hsu freebsd_committer 2019-12-11 11:37:50 UTC
BME has been added back to the rotation.


Thanks for your help, at this point I believe the issue is at our side. I think you will be redirected to bme mirror soon after TTL expered. In the future we will make this mechanism more automatic.