Bug 242466 - [NEW PORT] net/hblock: Adblocker using automatically generated hosts file
Summary: [NEW PORT] net/hblock: Adblocker using automatically generated hosts file
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitri Goutnik
URL: https://github.com/hectorm/hblock
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-06 00:13 UTC by Lewis Cook
Modified: 2020-04-12 20:27 UTC (History)
4 users (show)

See Also:


Attachments
hblock port diff (2.74 KB, patch)
2019-12-06 00:13 UTC, Lewis Cook
no flags Details | Diff
hblock port diff (2.74 KB, patch)
2019-12-12 17:22 UTC, Lewis Cook
no flags Details | Diff
hblock port diff (13.39 KB, text/plain)
2020-01-12 18:40 UTC, Lewis Cook
no flags Details
hblock-2.1.3.log (13.39 KB, text/plain)
2020-01-12 18:41 UTC, Lewis Cook
no flags Details
hblock-2.1.5.diff (3.88 KB, patch)
2020-04-05 21:16 UTC, Lewis Cook
no flags Details | Diff
hblock-2.1.5.log (12.61 KB, text/plain)
2020-04-05 21:17 UTC, Lewis Cook
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lewis Cook freebsd_triage 2019-12-06 00:13:26 UTC
Created attachment 209744 [details]
hblock port diff

POSIX-compliant shell script, designed for Unix-like systems,
gets a list of domains that serve ads, tracking scripts and
malware from multiple sources and creates a hosts file that
prevents your system from connecting to them.

WWW: https://github.com/hectorm/hblock

QA:
 * portlint: looks fine;
 * portclippy: in accordance; 
 * poudriere: package built, application works as intended.
Comment 1 Lewis Cook freebsd_triage 2019-12-12 17:22:40 UTC
Created attachment 209898 [details]
hblock port diff

* Bump to version 2.1.3.
Comment 2 Lewis Cook freebsd_triage 2020-01-12 18:40:23 UTC
Created attachment 210664 [details]
hblock port diff
Comment 3 Lewis Cook freebsd_triage 2020-01-12 18:41:44 UTC
Created attachment 210666 [details]
hblock-2.1.3.log

* Poudriere build log.
Comment 4 Lewis Cook freebsd_triage 2020-04-05 21:16:58 UTC
Created attachment 213108 [details]
hblock-2.1.5.diff

* Bumped DISTVERSION to 2.1.5 and update distinfo;
* Include 'files/patch-hblock', use base system fetch instead rather than 'curl'/'wget';
* Add 'ca_root_nss' to RUN_DEPENDS;
* Minor cleanup.
Comment 5 Lewis Cook freebsd_triage 2020-04-05 21:17:43 UTC
Created attachment 213109 [details]
hblock-2.1.5.log

* Poudriere build log.
Comment 6 Michael Muenz 2020-04-09 15:13:42 UTC
I was able to build via usual ports and the program runs fine, nice addition! 
I'm adding Ben so we might get this in a bit quicker. :)

Thanks!
Comment 7 commit-hook freebsd_committer 2020-04-12 20:27:06 UTC
A commit references this bug:

Author: dmgk
Date: Sun Apr 12 20:26:33 UTC 2020
New revision: 531555
URL: https://svnweb.freebsd.org/changeset/ports/531555

Log:
  New port: net/hblock

  POSIX-compliant shell script, designed for Unix-like systems,
  gets a list of domains that serve ads, tracking scripts and
  malware from multiple sources and creates a hosts file that
  prevents your system from connecting to them.

  WWW: https://github.com/hectorm/hblock

  PR:		242466
  Submitted by:	Lewis Cook <vulcan@wired.sh>

Changes:
  head/net/Makefile
  head/net/hblock/
  head/net/hblock/Makefile
  head/net/hblock/distinfo
  head/net/hblock/files/
  head/net/hblock/files/patch-hblock
  head/net/hblock/pkg-descr
Comment 8 Dmitri Goutnik freebsd_committer 2020-04-12 20:27:33 UTC
Committed, thanks!