Bug 242479 - deskutils/owncloudclient: Update to 2.6.0
Summary: deskutils/owncloudclient: Update to 2.6.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-06 11:29 UTC by Adriaan de Groot
Modified: 2019-12-30 22:35 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (yonas)


Attachments
update to the port directory (svn diff) (4.09 KB, patch)
2019-12-06 11:29 UTC, Adriaan de Groot
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adriaan de Groot freebsd_committer 2019-12-06 11:29:00 UTC
Created attachment 209754 [details]
update to the port directory (svn diff)

The latest owncloudclient is 2.6.0 (https://owncloud.org/changelog/desktop-client/ , released end of november). Here's an update to the port, **but** it is not complete because github returns a tarball with an empty zsync/ source directory. I've contacted upstream about that.
Comment 1 Adriaan de Groot freebsd_committer 2019-12-06 15:50:45 UTC
Better tarball:

```
-DISTVERSIONPREFIX=     v
-DISTVERSION=   2.4.1
-PORTREVISION=  5
+DISTVERSION=   2.6.0
+DISTVERSIONSUFFIX=     .13018
 CATEGORIES=    deskutils
+MASTER_SITES=  https://download.owncloud.com/desktop/stable/
+# owncloudclient-2.6.0.13018.tar.xz
```
Comment 2 Adriaan de Groot freebsd_committer 2019-12-08 11:25:20 UTC
FWIW, maintainer's email address is bouncing.

```
<<< 550 No Such User Here
```
Comment 3 commit-hook freebsd_committer 2019-12-30 22:31:04 UTC
A commit references this bug:

Author: adridg
Date: Mon Dec 30 22:30:18 UTC 2019
New revision: 521570
URL: https://svnweb.freebsd.org/changeset/ports/521570

Log:
  Update deskutils/owncloudclient to latest upstream release

  Maintainer email is bouncing (although it was ok in august or so).
  OwnCloud staff approached me at Linux App Summit asking for the
  port to be updated, which is why I'm chasing it now after
  maintainer timeout.

  The changelog is at
  	https://owncloud.org/changelog/desktop-client/

  There are over 18 months of updates, so I'm not going to summarize
  them. One thing that **did** change is the documentation: the
  manpage is supposed to be built with sphinx, but the rst files
  needed for that are missing from the tarball. I've reported that
  upstream.

  PR:		242479
  Approved by:	maintainer-timeout (24 days)

Changes:
  head/deskutils/owncloudclient/Makefile
  head/deskutils/owncloudclient/distinfo
  head/deskutils/owncloudclient/files/patch-doc_CMakeLists.txt
  head/deskutils/owncloudclient/files/patch-src_gui_accountsettings.cpp
  head/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp
  head/deskutils/owncloudclient/pkg-plist
Comment 4 Adriaan de Groot freebsd_committer 2019-12-30 22:35:51 UTC
Updated as intended, although it took some hacking away of the documentation.