Bug 242494 - devel/asteroid1: does not support python 3.7+
Summary: devel/asteroid1: does not support python 3.7+
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-07 01:26 UTC by Enji Cooper
Modified: 2019-12-08 14:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Enji Cooper freebsd_committer 2019-12-07 01:26:57 UTC
Per this upstream commit, devel/asteroid1 doesn’t support features in python 3.7+: https://github.com/PyCQA/pylint/commit/1448b32cd0dba1e866d1a2c0702f1d3f987f719c . The port(s) should be blacklisted with python 3.7+.
Comment 1 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-12-08 14:26:40 UTC
(In reply to Enji Cooper from comment #0)

Do you mean devel/pylint1? This port was added mainly for python 2.7 users because it is not supported by pylint 2.x.
Comment 2 Enji Cooper freebsd_committer 2019-12-08 14:29:51 UTC
(In reply to Sunpoet Po-Chuan Hsieh from comment #1)

Technically both as asteroid1, which pylint1 is a dependency of, isn’t python 3.7 compatible.