Bug 242510 - net/chrony: Not linking to nettle library
Summary: net/chrony: Not linking to nettle library
Status: Closed DUPLICATE of bug 244534
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Matthias Andree
URL:
Keywords:
Depends on:
Blocks: 244534
  Show dependency treegraph
 
Reported: 2019-12-08 19:15 UTC by Matt Smith
Modified: 2020-04-05 21:27 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (yonas)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Smith 2019-12-08 19:15:43 UTC
I've just noticed that chrony isn't linked with the nettle library despite nettle being enabled as default.

If you look at the build log from poudriere ( http://beefy6.nyi.freebsd.org/data/latest-per-pkg/chrony/3.5/120amd64-default.log ) it shows the port installing nettle but then during the configure stage it says nettle is not found and SECHASH is disabled.

===>   chrony-3.5 depends on shared library: libnettle.so - found (/usr/local/lib/libnettle.so)

Checking for nettle : No
Features : +CMDMON +NTP +REFCLOCK -RTC +PRIVDROP -SCFILTER -SIGND +ASYNCDNS +READLINE -SECHASH +IPV6 -DEBUG
Comment 1 Matthias Andree freebsd_committer 2020-04-05 20:08:43 UTC
Fix ordering of bugs.
Comment 2 Matthias Andree freebsd_committer 2020-04-05 20:54:19 UTC

*** This bug has been marked as a duplicate of bug 244534 ***
Comment 3 commit-hook freebsd_committer 2020-04-05 21:27:00 UTC
A commit references this bug:

Author: mandree
Date: Sun Apr  5 21:20:11 UTC 2020
New revision: 530840
URL: https://svnweb.freebsd.org/changeset/ports/530840

Log:
  net/chrony: make NETTLE build robust, improve rc script, re-enable NSS

  Changes by Colin T.:
  * Always require pkgconfig instead of only requiring it for NSS,
    because otherwise chrony does not link reliably to nettle. [1]
  * Add pidfile to rc.d script to stop it from complaining when
    stopping chronyd. [1]
  * Document chronyd_* options in rc.d script. [1]

  Changes by Matthias Andree:
  * Move USES line up to please portlint.
  * Add HTMLDOCS option, to build and install HTML docs. IMPLIES DOCS.
    Needs textproc/asciidoctor (rubygem) as build requisite.
  * Turn CRYPTLIB into a _RADIO to choose at most one from NSS + NETTLE.
  * Under WITH_DEBUG, add --enable-debug to CONFIGURE_ARGS.
  * Remove @ (silent) from Makefile commands.
  * Remove NSS_BROKEN, chrony 3.5 appears to work with NSS. Updates [3].

  PR:		244534 [1]
  PR:		242510 [2]
  PR:		223840 [3]
  Submitted by:	Colin T. <bugzilla@nulldir.e4ward.com> [1]
  Reported by:	Matt Smith <freebsd@xtaz.uk> [2]
  Approved by:	maintainer timeout (yonas@fizk.net, 36 days)

Changes:
  head/net/chrony/Makefile
  head/net/chrony/files/chronyd.in
  head/net/chrony/pkg-plist