Bug 242562 - [NEW PORT] devel/py-b2sdk: python B2 SDK
Summary: [NEW PORT] devel/py-b2sdk: python B2 SDK
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: feature, needs-patch, needs-qa
Depends on:
Blocks: 241138
  Show dependency treegraph
 
Reported: 2019-12-10 23:42 UTC by Henry David Bartholomew
Modified: 2020-01-11 23:24 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback? (PopularMoment)


Attachments
shar archive (2.44 KB, text/plain)
2019-12-10 23:42 UTC, Henry David Bartholomew
no flags Details
py-b2sdk (2.49 KB, patch)
2020-01-11 23:24 UTC, Henry David Bartholomew
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Henry David Bartholomew 2019-12-10 23:42:54 UTC
Created attachment 209847 [details]
shar archive

New port devel/py-b2sdk which will be required by forthcoming update to b2/py-b2.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-01-11 15:52:10 UTC
Review items:

- MAINTAINER should be author or real person. python@ is ok as a fallback maintainer for existing ports, not new ports

- Add LICENSE_FILE (one is provided in the PyPI sdist)

- Match RUN_DEPENDS exactly to those in install_requires, in particular, adding the max version for arrow in the case of <=3.4

- Add TEST_DEPENDS (patch out pyflakes, and patch == to >=) and test target for QA
Comment 2 Henry David Bartholomew 2020-01-11 23:24:32 UTC
Created attachment 210642 [details]
py-b2sdk

Changes:

- updated MAINTAINER

- added LICENSE_FILE

- updated RUN_DEPENDS with actual requirements.txt taking into account the arrow patch taken from https://github.com/Backblaze/b2-sdk-python/commit/03aa9bc3c58ce6247cd02b6fa4be182b288fe22d#diff-b4ef698db8ca845e5845c4618278f29a

- The included tests do not work in version v0.1.8 and a test target has been intentionally omitted.

Note that although tests are including the the pypi v0.1.8 archive, in a later version that is available v1.0.2 the tests have been entirely removed from the pypi archive.

The tests from the github version of v1.0.2 do work, but...

Why not use version 1.0.2 of b2sdk? Because the latest *released* version v1.4.2 of the command line client py-b2 does not work with the later version of the b2sdk.

So in short till B2 (py-b2) v1.4.3 is released, no tests.