Bug 242588 - graphics/inkscape: drop ImageMagick6 dependency
Summary: graphics/inkscape: drop ImageMagick6 dependency
Status: Closed DUPLICATE of bug 243615
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-11 23:22 UTC by Tatsuki Makino
Modified: 2020-05-04 21:57 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
Proposed patch for graphics/inkscape (6.48 KB, patch)
2019-12-11 23:22 UTC, Tatsuki Makino
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tatsuki Makino 2019-12-11 23:22:18 UTC
Created attachment 209880 [details]
Proposed patch for graphics/inkscape

Since Inkscape has a fixed dependency on ImageMagick6, it cannot be installed in an environment where ImageMagick7 is installed.
ImageMagick is:
> Optional Dependencies Needed for Bitmap editing extensions, bitmap import resolution
Isn't it necessary by default?
Comment 1 Greg V 2020-01-26 15:59:33 UTC
Check out bug 243615, in my inkscape 1.0 beta patch I set it to default to GraphicsMagick
Comment 2 Tatsuki Makino 2020-01-26 23:11:51 UTC
(In reply to Greg V from comment #1)

Thank you.
attachment 209880 [details] has a OPTIONS_RADIO_IMAGEMAGICK switch between ImageMagick6 and ImageMagick7 that mimics graphics/zbar.
And it includes a patch to combine with ImageMagick7.
If inkscape-1.0beta2 doesn't improve for ImageMagick7, and if inkscape still use ImageMagick, please take it :)
Comment 3 Tatsuki Makino 2020-05-04 21:57:10 UTC

*** This bug has been marked as a duplicate of bug 243615 ***