Bug 242639 - [NEW PORT] sysutils/fselect: Find files with SQL-like queries
Summary: [NEW PORT] sysutils/fselect: Find files with SQL-like queries
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias C. Berner
URL: https://github.com/jhspetersson/fselect
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-15 00:59 UTC by Lewis Cook
Modified: 2020-03-08 18:19 UTC (History)
1 user (show)

See Also:


Attachments
port diff (20.47 KB, patch)
2019-12-15 00:59 UTC, Lewis Cook
no flags Details | Diff
fselect-0.6.7.diff (20.47 KB, patch)
2019-12-18 22:59 UTC, Lewis Cook
no flags Details | Diff
fselect-0.6.8.diff (20.91 KB, patch)
2020-01-08 16:50 UTC, Lewis Cook
vulcan: maintainer-approval+
Details | Diff
fselect-0.6.8.log (109.68 KB, text/plain)
2020-01-08 16:51 UTC, Lewis Cook
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lewis Cook 2019-12-15 00:59:10 UTC
Created attachment 209958 [details]
port diff

Command-line utility to find files with a
highly relaxed SQL-like syntax, whilst
supporting a number of different complex
queries.

WWW: https://github.com/jhspetersson/fselect

QA:
 * portlint: looks fine;
 * poudriere: package built, application works as intended.
Comment 1 Lewis Cook 2019-12-18 22:59:25 UTC
Created attachment 210046 [details]
fselect-0.6.7.diff

* Use ${MAN1PREFIX} in place of the man page installation.
Comment 2 Lewis Cook 2020-01-08 16:50:29 UTC
Created attachment 210539 [details]
fselect-0.6.8.diff

* Bump to version 0.6.8.
Comment 3 Lewis Cook 2020-01-08 16:51:47 UTC
Created attachment 210540 [details]
fselect-0.6.8.log

* Poudriere build logs. Application compiled and package built - works as expected.
Comment 4 Tobias C. Berner freebsd_committer 2020-03-08 18:19:14 UTC
Committed. Thanks.
Comment 5 commit-hook freebsd_committer 2020-03-08 18:19:26 UTC
A commit references this bug:

Author: tcberner
Date: Sun Mar  8 18:18:33 UTC 2020
New revision: 528063
URL: https://svnweb.freebsd.org/changeset/ports/528063

Log:
  New port: sysutils/fselect: Find files with SQL-like queries

  Command-line utility to find files with a
  highly relaxed SQL-like syntax, whilst
  supporting a number of different complex
  queries.

  WWW: https://github.com/jhspetersson/fselect

  PR:		242639
  Submitted by:	Lewis Cook <vulcan@wired.sh>

Changes:
  head/sysutils/Makefile
  head/sysutils/fselect/
  head/sysutils/fselect/Makefile
  head/sysutils/fselect/distinfo
  head/sysutils/fselect/pkg-descr