Bug 242641 - pkg-fallout@ archiving ends after 2019-10-12
Summary: pkg-fallout@ archiving ends after 2019-10-12
Status: Closed Works As Intended
Alias: None
Product: Services
Classification: Unclassified
Component: Mailing Lists (show other bugs)
Version: unspecified
Hardware: Any Any
: --- Affects Some People
Assignee: postmaster
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-15 01:46 UTC by Jan Beich
Modified: 2019-12-15 04:14 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2019-12-15 01:46:32 UTC
https://lists.freebsd.org/pipermail/freebsd-pkg-fallout/ doesn't have archives for Monday 14 October 2019 or later. The last entry is from "Sat Oct 12 21:52:05 UTC 2019". While one could look at pkg-status for build errors instead the logs sometimes disappear if machines are turned off or repurposed.
Comment 1 Philip Paeps freebsd_committer 2019-12-15 04:11:49 UTC
Look towards the bottom of the page.

We changed archiving for pkg-fallout@ to keep daily archives rather than weekly archives in October.  The sorting on the pipermail archive page is a bit silly.

The reason we changed the archiving to daily instead of weekly is that pipermail reads the entire current archive before appending a new message.  Towards the end of the week, that causes a lot of memory pressure and slows down archiving and delivery for all other lists.

This is still not an ideal solution, but it's the best we can do without keeping local patches against Mailman.
Comment 2 Philip Paeps freebsd_committer 2019-12-15 04:14:01 UTC
See for example: https://lists.freebsd.org/pipermail/freebsd-pkg-fallout/20191215/thread.html

You may also find the archives on https://docs.freebsd.org/mail/current/freebsd-pkg-fallout.html easier to follow.