Bug 242681 - net/samba410: 4.10.11 fails to package in quarterly (2019Q4) branch
Summary: net/samba410: 4.10.11 fails to package in quarterly (2019Q4) branch
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Many People
Assignee: Timur I. Bakeyev
URL:
Keywords: needs-patch, needs-qa, regression
Depends on:
Blocks:
 
Reported: 2019-12-17 10:33 UTC by andriys
Modified: 2020-04-05 20:40 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (timur)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andriys 2019-12-17 10:33:36 UTC
Build of net/samba410 from the ^/branches/2019Q4 (current quarterly branch) fails with the following error:

===>  Building package for samba410-4.10.11
pkg-static: Unable to access file /construction/xports/net/samba410/work/stage/usr/local/lib/samba4/modules/vfs/glusterfs_fuse.so:No such file or directory
pkg-static: Unable to access file /construction/xports/net/samba410/work/stage/usr/local/man/man8/vfs_glusterfs_fuse.8.gz:No such file or directory
*** Error code 1

Stop.
make: stopped in /xports/net/samba410


And this feels to be the reason the samba410 PACKAGE HAS DISAPPEARED FROM THE OFFICIAL QUARTERLY PACKAGE REPO.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-12-17 10:38:28 UTC
Regression post ports r520052 (MFH 4.10.11 of ports r520047)
Comment 2 commit-hook freebsd_committer 2019-12-18 22:23:01 UTC
A commit references this bug:

Author: timur
Date: Wed Dec 18 22:22:04 UTC 2019
New revision: 520405
URL: https://svnweb.freebsd.org/changeset/ports/520405

Log:
  Add missing updates to catch up net/samba410 4.10.8 -> 4.10.11 changes.

  PR:		242681
  Approved by:	portmgr (implicit, packaging fix)
  MFH:		2019Q4 (packaging fix)

Changes:
  branches/2019Q4/net/samba410/Makefile
  branches/2019Q4/net/samba410/files/0001-Zfs-provision-1.patch
  branches/2019Q4/net/samba410/files/0001-provision-use-ASCII-quotes.patch
  branches/2019Q4/net/samba410/pkg-plist