Bug 242726 - dns/knot2 version 2.9.1 fails to build on amd64
Summary: dns/knot2 version 2.9.1 fails to build on amd64
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-19 14:15 UTC by Alarig Le Lay
Modified: 2020-01-23 10:32 UTC (History)
2 users (show)

See Also:
freebsd: maintainer-feedback+


Attachments
full build log (476.57 KB, text/plain)
2019-12-19 14:15 UTC, Alarig Le Lay
no flags Details
Knot DNS 2.9.2 (2.27 KB, patch)
2019-12-20 00:12 UTC, Leo Vandewoestijne
freebsd: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alarig Le Lay 2019-12-19 14:15:54 UTC
Created attachment 210064 [details]
full build log

Hi,

I think that the revelent part of the log is here:
--- knsec3hash ---
/usr/local/lib/libidn2.so.0:(.text+0x22a0): multiple definition of `_idn2_punycode_encode@IDN2_0.0.0'
/usr/local/lib/libidn2.so.0:(.text+0x2680): multiple definition of `_idn2_punycode_decode@IDN2_0.0.0'
cc: error: linker command failed with exit code 1 (use -v to see invocation)
*** [knsec3hash] Error code 1

However, I didn’t enabled IDN and it’s disabled by default, the full log is attached.

Regards,
-- 
Alarig Le Lay
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-12-19 14:57:29 UTC
Seems it is this in libidn2:

https://gitlab.com/libidn/libidn2/commit/089616574679a017f5d45c6bd40b05816ae4db6b
Comment 2 Walter Schwarzenfeld freebsd_triage 2019-12-19 14:58:44 UTC
CC'd libidn2 maintainer.
Comment 3 Leo Vandewoestijne 2019-12-19 18:18:52 UTC
Thanks,
I became aware of the problem.
It is / will be solved in PR 242665
Comment 4 Leo Vandewoestijne 2019-12-20 00:12:39 UTC
Created attachment 210074 [details]
Knot DNS 2.9.2

Since it's usual to have one commit per PR;
maybe let's first apply this patch - which will solve this problem,
instead of trying to solve everything at once.
Comment 5 Alarig Le Lay 2019-12-24 15:39:04 UTC
The port built this night :)
Comment 6 Leo Vandewoestijne 2019-12-25 22:20:12 UTC
Still every single mutation in my patch is an improvement.
I'd prefer to have it committed ahead of closing PR 242665, which still should solve the long ongoing i386 atomic issue.
Comment 7 Leo Vandewoestijne 2020-01-22 15:21:50 UTC
This PR can be closed.

It's addressed in PR 242665 (in case it still was a problem).
Comment 8 Sunpoet Po-Chuan Hsieh freebsd_committer 2020-01-23 10:32:00 UTC
The mentioned problem caused by libidn2 was fixed in r520636.