Bug 242748 - [NEW PORT] sysutils/inxi: Full featured CLI system information tool
Summary: [NEW PORT] sysutils/inxi: Full featured CLI system information tool
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL: https://github.com/smxi/inxi
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-20 22:53 UTC by Lewis Cook
Modified: 2020-09-02 18:31 UTC (History)
0 users

See Also:


Attachments
inxi-3.0.37.1.diff (5.19 KB, patch)
2019-12-20 22:53 UTC, Lewis Cook
no flags Details | Diff
inxi-3.0.37.1.diff (5.19 KB, patch)
2019-12-20 23:06 UTC, Lewis Cook
no flags Details | Diff
inxi-3.1.06.1.diff (3.30 KB, patch)
2020-09-02 15:20 UTC, Lewis Cook
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lewis Cook freebsd_triage 2019-12-20 22:53:00 UTC
Created attachment 210086 [details]
inxi-3.0.37.1.diff

inxi is a command line system information tool. It was forked
from the ancient and mindbendingly perverse yet ingenius
infobash, by locsmif.

The primary purpose of inxi is for support, and sys admin use.
inxi is used widely for forum and IRC support.

WWW: https://github.com/smxi/inxi

QA:
 * portlint: few minor warnings, no errors;
 * poudriere: package built, application works as intended.
Comment 1 Lewis Cook freebsd_triage 2019-12-20 23:06:22 UTC
Created attachment 210087 [details]
inxi-3.0.37.1.diff

* Fix typo in P5-XML_DESC, s/infromation/information/.
Comment 2 Lewis Cook freebsd_triage 2020-09-02 15:20:54 UTC
Created attachment 217706 [details]
inxi-3.1.06.1.diff

* Update to 3.1.06.1 and simplify Makefile.
Comment 3 commit-hook freebsd_committer 2020-09-02 18:30:44 UTC
A commit references this bug:

Author: swills
Date: Wed Sep  2 18:30:06 UTC 2020
New revision: 547373
URL: https://svnweb.freebsd.org/changeset/ports/547373

Log:
  sysutils/inxi: create port

  inxi is a command line system information tool. It was forked
  from the ancient and mindbendingly perverse yet ingenius
  infobash, by locsmif.

  The primary purpose of inxi is for support, and sys admin use.
  inxi is used widely for forum and IRC support.

  WWW: https://github.com/smxi/inxi

  PR:		242748
  Submitted by:	Lewis Cook <vulcan@wired.sh>

Changes:
  head/sysutils/Makefile
  head/sysutils/inxi/
  head/sysutils/inxi/Makefile
  head/sysutils/inxi/distinfo
  head/sysutils/inxi/pkg-descr
Comment 4 Steve Wills freebsd_committer 2020-09-02 18:31:55 UTC
Committed, thanks!