Created attachment 210093 [details]
* portlint: OK (looks fine.)
* testport: OK (poudriere: 12.0, amd64 tested)
* maketest: OK (6 passed, 4 deselected)
1) USES=python:<version-spec> is incorrect. 3.5+ incorrectly limits version support to >= 3.5 ...
Upstream declares support for 2.6,2.7,3.3,3.4.
USES=python:<version-spec> should match this as closely as possible without being incorrect, modulo any syntax limitations in <version-spec> (doesn't support !=, etc).
USES=python is the most correct in this case.
However, if a package doesn't declare support for certain versions, but they are allowed by <version-spec>, port maintainer should QA (test suite) extensively with those undeclared versions to ensure they work, otherwise limit the versions accordingly. In this case, this means explicit QA/test suite testing for 3.5+
2) package dependencies declare versions , *_DEPENDS should match these as closely as possible
 install_requires=['pytest-cache', 'pytest>=2.4.2', 'pep8>=1.3', ],
Note: I've already fixed comment 1 issues locally, no need to update patch
Python 3.5: 6 passed, 4 deselected in 1.43 seconds
Python 3.6: 6 passed, 4 deselected in 1.55 seconds
Python 3.7: 6 passed, 4 deselected in 0.88 seconds
Python 3.8: 6 passed, 4 deselected in 1.54 seconds
Python 2.7: 6 passed, 4 deselected in 1.55 seconds
A commit references this bug:
Date: Sat Jan 11 13:45:38 UTC 2020
New revision: 522685
[NEW] devel/py-pytest-pep8: Pytest plugin to check PEP8 requirements
This plugin allows to configure on a per-project and per-file basis which
errors or warnings to care about.
Submitted by: Goran Meki? <firstname.lastname@example.org>
Committed with changes:
- Those listed in comment 1
- Tweak COMMENT (match setup.py:description)
Thank you Goran!