Bug 242776 - [NEW PORT] x11-fonts/victor-mono-ttf: Programming font with cursive italics and ligatures
Summary: [NEW PORT] x11-fonts/victor-mono-ttf: Programming font with cursive italics a...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL: https://github.com/rubjo/victor-mono
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-21 17:50 UTC by Lewis Cook
Modified: 2020-01-12 16:10 UTC (History)
0 users

See Also:


Attachments
victor-mono-ttf-1.3.0.diff (4.27 KB, patch)
2019-12-21 17:50 UTC, Lewis Cook
no flags Details | Diff
victor-mono-ttf-1.3.0.diff (4.30 KB, patch)
2019-12-21 18:17 UTC, Lewis Cook
no flags Details | Diff
victor-mono-ttf-1.3.0.log (14.47 KB, text/plain)
2020-01-11 11:15 UTC, Lewis Cook
no flags Details
victor-mono-ttf-1.3.0.diff (4.26 KB, patch)
2020-01-11 13:19 UTC, Lewis Cook
no flags Details | Diff
victor-mono-ttf-1.3.0.log (14.55 KB, text/plain)
2020-01-11 13:19 UTC, Lewis Cook
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lewis Cook 2019-12-21 17:50:07 UTC
Created attachment 210109 [details]
victor-mono-ttf-1.3.0.diff

Victor Mono is a free programming font with
optional semi-connected cursive italics,
symbol ligatures (!=, ->>, =>, ===, <=, >=, ++)
and Latin, Cyrillic and Greek characters.

The typeface is clean, crisp and narrow,
with a large x-height and clear punctuation,
making it legible and ideal for code. It comes
in seven weights, and is available in Roman,
Italic and Oblique.

WWW: https://rubjo.github.io/victor-mono/

QA:
 * portlint: looks fine;
 * poudriere: package built, application works as intended.
Comment 1 Lewis Cook 2019-12-21 18:17:29 UTC
Created attachment 210111 [details]
victor-mono-ttf-1.3.0.diff

* Added FONTNAME declaration;
* Added -q flag to ${UNZIP_NATIVE_CMD}.
Comment 2 Lewis Cook 2020-01-11 11:15:19 UTC
Created attachment 210616 [details]
victor-mono-ttf-1.3.0.log

* Poudriere build log.
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2020-01-11 12:13:10 UTC
You could extract *.ttf fonts to FONTSDIR directly.

Use either

${TAR} -x -C ${STAGEDIR}${FONTSDIR} -f ${WRKSRC}/public/VictorMonoAll.zip --strip-components 1 'TTF/*.ttf'

or 

${UNZIP_NATIVE_CMD} -d ${STAGEDIR}${FONTSDIR} -j ${WRKSRC}/public/VictorMonoAll.zip 'TTF/*.ttf'
Comment 4 Sunpoet Po-Chuan Hsieh freebsd_committer 2020-01-11 12:38:20 UTC
Forgot to say that I prefer using TAR.

BTW, could we just download VictorMonoAll.zip (~5MB) instead of source tarball (~13MB)?
Comment 5 Lewis Cook 2020-01-11 13:18:23 UTC
(In reply to Sunpoet Po-Chuan Hsieh from comment #4)
Thanks! Makes much more sense doing this - changed the Makefile with your suggestions. Although, we can use the 'zip' option in 'USES' which handles the extraction for us. :)
Comment 6 Lewis Cook 2020-01-11 13:19:07 UTC
Created attachment 210619 [details]
victor-mono-ttf-1.3.0.diff
Comment 7 Lewis Cook 2020-01-11 13:19:56 UTC
Created attachment 210620 [details]
victor-mono-ttf-1.3.0.log

* Updated build log.
Comment 8 Sunpoet Po-Chuan Hsieh freebsd_committer 2020-01-12 16:09:23 UTC
Committed. Thanks!
Comment 9 commit-hook freebsd_committer 2020-01-12 16:10:00 UTC
A commit references this bug:

Author: sunpoet
Date: Sun Jan 12 16:09:19 UTC 2020
New revision: 522818
URL: https://svnweb.freebsd.org/changeset/ports/522818

Log:
  Add victor-mono-ttf 1.3.0

  Victor Mono is a free programming font with optional semi-connected cursive
  italics, symbol ligatures (!=, ->>, =>, ===, <=, >=, ++) and Latin,
  Cyrillic and Greek characters.

  The typeface is clean, crisp and narrow, with a large x-height and clear
  punctuation, making it legible and ideal for code. It comes in seven
  weights, and is available in Roman, Italic and Oblique.

  WWW: https://rubjo.github.io/victor-mono/

  PR:		242776
  Submitted by:	Lewis Cook <vulcan@wired.sh>

Changes:
  head/x11-fonts/Makefile
  head/x11-fonts/victor-mono-ttf/
  head/x11-fonts/victor-mono-ttf/Makefile
  head/x11-fonts/victor-mono-ttf/distinfo
  head/x11-fonts/victor-mono-ttf/pkg-descr
  head/x11-fonts/victor-mono-ttf/pkg-plist