Bug 242790 - www/firefox does not compile when x11-toolkits/gtk30 is built without WAYLAND
Summary: www/firefox does not compile when x11-toolkits/gtk30 is built without WAYLAND
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gecko (Nobody)
URL:
Keywords:
: 242791 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-12-22 05:40 UTC by jakub_lach
Modified: 2019-12-24 04:02 UTC (History)
6 users (show)

See Also:
bugzilla: maintainer-feedback? (gecko)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jakub_lach 2019-12-22 05:40:17 UTC
In file included from Unified_cpp_toolkit_xre0.cpp:56:
/usr/obj/usr/ports/www/firefox/work/firefox-71.0/toolkit/xre/glxtest.cpp:39:10: fatal error: 
      'mozilla/widget/mozwayland.h' file not found
#include "mozilla/widget/mozwayland.h"
         ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Comment 1 Jan Beich freebsd_committer 2019-12-22 05:47:22 UTC
Did you build x11-toolkits/gtk30 without WAYLAND option? ports r520537 builds fine on the package cluster.

http://beefy6.nyi.freebsd.org/data/120amd64-default/520537/logs/firefox-71.0_4,1.log
Comment 2 Jan Beich freebsd_committer 2019-12-22 05:51:31 UTC
Greg, can you add missing MOZ_WAYLAND guards upstream? After that I'll backport to ports.
Comment 3 jakub_lach 2019-12-22 05:55:00 UTC
Yes, indeed.
Comment 4 jakub_lach 2019-12-22 14:06:23 UTC
(In reply to jakub_lach from comment #3)

Is WAYLAND obligatory now?
Comment 5 gja822 2019-12-22 16:45:25 UTC
The same is here. I try to not use WAYLAND anywhere I can (cause I see no advantages for me).
Comment 6 Jan Beich freebsd_committer 2019-12-22 18:51:07 UTC
(In reply to jakub_lach from comment #4)
> Is WAYLAND obligatory now?

Not yet but it's not tested here or upstream. Until there's a fix just remove files/patch-bug1556301.
Comment 7 Jan Beich freebsd_committer 2019-12-22 18:54:04 UTC
*** Bug 242791 has been marked as a duplicate of this bug. ***
Comment 8 Greg V 2019-12-24 00:53:52 UTC
(In reply to Jan Beich from comment #2)
Updated (haven't tested but seems correct)
Comment 9 commit-hook freebsd_committer 2019-12-24 04:01:11 UTC
A commit references this bug:

Author: jbeich
Date: Tue Dec 24 04:00:59 UTC 2019
New revision: 520772
URL: https://svnweb.freebsd.org/changeset/ports/520772

Log:
  www/firefox: unbreak after r520537 if gtk3 lacks Wayland support

  In file included from Unified_cpp_toolkit_xre0.cpp:56:
  toolkit/xre/glxtest.cpp:39:10: fatal error: 'mozilla/widget/mozwayland.h' file not found
   #include "mozilla/widget/mozwayland.h"
            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~

  PR:		242790
  Reported by:	many
  Submitted by:	Greg V

Changes:
  head/www/firefox/files/patch-bug1556301