Bug 242803 - [NEW PORT] textproc/py-text-unidecode: Most basic Text::Unidecode port
Summary: [NEW PORT] textproc/py-text-unidecode: Most basic Text::Unidecode port
Status: Closed Not Accepted
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ben Woods
URL:
Keywords: patch, patch-ready
Depends on:
Blocks: 242805
  Show dependency treegraph
 
Reported: 2019-12-22 15:00 UTC by Goran Mekić
Modified: 2019-12-23 23:41 UTC (History)
1 user (show)

See Also:


Attachments
py-text-unidecode.diff (2.00 KB, patch)
2019-12-22 15:00 UTC, Goran Mekić
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Goran Mekić 2019-12-22 15:00:53 UTC
Created attachment 210140 [details]
py-text-unidecode.diff
Comment 1 Goran Mekić 2019-12-22 15:01:45 UTC
QA:

  * portlint: OK (looks fine.)
  * testport: OK (poudriere: 12.0, amd64 tested)
  * maketest: OK (133 passed tests)
Comment 2 commit-hook freebsd_committer 2019-12-23 23:01:15 UTC
A commit references this bug:

Author: woodsb02
Date: Mon Dec 23 23:00:57 UTC 2019
New revision: 520749
URL: https://svnweb.freebsd.org/changeset/ports/520749

Log:
  Add new port textproc/py-text-unidecode

  Text-unidecode is the most basic port of the Text::Unidecode Perl library.

  WWW: https://github.com/kmike/text-unidecode/

  PR:		242803
  Submitted by:	Goran Meki? <meka@tilda.center>

Changes:
  head/textproc/Makefile
  head/textproc/py-text-unidecode/
  head/textproc/py-text-unidecode/Makefile
  head/textproc/py-text-unidecode/distinfo
  head/textproc/py-text-unidecode/pkg-descr
Comment 3 Ben Woods freebsd_committer 2019-12-23 23:04:59 UTC
Committed - thanks!
Comment 4 Ben Woods freebsd_committer 2019-12-23 23:14:36 UTC
Actually, it looks like this port already existed as converters/py-text-unidecode.

This new port textproc/py-text-unidecode is a duplicate of that existing port - I will remove this new port.
Comment 5 commit-hook freebsd_committer 2019-12-23 23:19:18 UTC
A commit references this bug:

Author: woodsb02
Date: Mon Dec 23 23:18:36 UTC 2019
New revision: 520752
URL: https://svnweb.freebsd.org/changeset/ports/520752

Log:
  Remove port textproc/py-text-unidecode, as it was a duplicate of port
  converters/py-text-unidecode

  PR:		242803

Changes:
  head/MOVED
  head/textproc/Makefile
  head/textproc/py-text-unidecode/