Bug 242886 - net/ceph13: update to mimic v13.2.8
Summary: net/ceph13: update to mimic v13.2.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-25 20:53 UTC by Willem Jan Withagen
Modified: 2020-01-09 19:21 UTC (History)
1 user (show)

See Also:


Attachments
diff for upgrade to 13.2.8 (5.65 KB, patch)
2019-12-25 20:53 UTC, Willem Jan Withagen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Willem Jan Withagen 2019-12-25 20:53:43 UTC
Created attachment 210229 [details]
diff for upgrade to 13.2.8

svn diff for upgrade to the 13.2.8 release.

svn status
M       Makefile
M       distinfo
M       files/file-git_version
?       files/patch-src_common_bit__vector.hpp
M       pkg-plist

Has passed:
    portlint -A
    poudriere testport
Comment 1 Willem Jan Withagen 2020-01-09 11:50:00 UTC
This is the eighth release in the Ceph Mimic stable release series. Its sole
purpose is to fix a regression that found its way into the previous release.
Notable Changes

    Due to a missed backport, clusters in the process of being upgraded from
    13.2.6 to 13.2.7 might suffer an OSD crash in build_incremental_map_msg.
    This regression was reported in https://tracker.ceph.com/issues/43106
    and is fixed in 13.2.8 (this release). Users of 13.2.6 can upgrade to 13.2.8
    directly – i.e., skip 13.2.7 – to avoid this.
Comment 2 Kurt Jaeger freebsd_committer 2020-01-09 19:21:15 UTC
Committed, thanks!
Comment 3 commit-hook freebsd_committer 2020-01-09 19:21:24 UTC
A commit references this bug:

Author: pi
Date: Thu Jan  9 19:21:11 UTC 2020
New revision: 522534
URL: https://svnweb.freebsd.org/changeset/ports/522534

Log:
  net/ceph13: upgrade 13.2.6 -> 13.2.8

  This is the eighth release in the Ceph Mimic stable release series. Its sole
  purpose is to fix a regression that found its way into the previous release.
  Notable Changes

    Due to a missed backport, clusters in the process of being upgraded from
    13.2.6 to 13.2.7 might suffer an OSD crash in build_incremental_map_msg.
    This regression was reported in https://tracker.ceph.com/issues/43106
    and is fixed in 13.2.8 (this release). Users of 13.2.6 can upgrade to
    13.2.8 directly, i.e. skip 13.2.7 to avoid this.

  PR:		242886
  Submitted by:	Willem Jan Withagen <wjw@digiware.nl> (maintainer)

Changes:
  head/net/ceph13/Makefile
  head/net/ceph13/distinfo
  head/net/ceph13/files/file-git_version
  head/net/ceph13/files/patch-src_common_bit__vector.hpp
  head/net/ceph13/pkg-plist