Bug 242910 - x11/xorg can not build with error python version problem and other things.
Summary: x11/xorg can not build with error python version problem and other things.
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-27 15:52 UTC by Ulas SAYGIN
Modified: 2020-04-15 20:06 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulas SAYGIN 2019-12-27 15:52:29 UTC
hi ,
i want to install xorg but i can not build because it asks llvm80 ports requirement does not provided, it asks python 3 at least, it says xorg specified as python 2.7 , even i tried to make python default version on make.conf
it didnt work.

I can continue this only by installing llvm80 installing but there are other ports who needs attention.

but i think it is first point, i will also tell other things but if someone try to do , i think he/she will see other points.


Error is like this.

====> Compressing man pages (compress-man)
===>  Installing for python27-2.7.17_1
===>  Checking if python27 is already installed
===>   Registering installation for python27-2.7.17_1 as automatic
Installing python27-2.7.17_1...
Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===> SECURITY REPORT:
      This port has installed the following files which may act as network
      servers and may therefore pose a remote security risk to the system.
/usr/local/lib/python2.7/lib-dynload/_socket.so

      If there are vulnerabilities in these programs there may be a security
      risk to the system. FreeBSD makes no guarantee about the security of
      ports included in the Ports Collection. Please type 'make deinstall'
      to deinstall the port if this is a concern.

      For more information, and contact details about the security
      status of this software, see the following webpage:
https://www.python.org/
===>   mesa-dri-18.3.2_9 depends on file: /usr/local/bin/python2.7 - found
===>   Returning to build of mesa-dri-18.3.2_9
===>   mesa-dri-18.3.2_9 depends on package: llvm80>=3.9.0_4 - not found
===>  llvm80-8.0.1_3 needs Python 3.6 at least, but 2.7 was specified.
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/devel/llvm80
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/graphics/mesa-dri
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/graphics/mesa-dri
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/x11/xorg
*** Error code 1

Stop.
make: stopped in /usr/ports/x11/xorg
Comment 1 Ulas SAYGIN 2019-12-27 15:53:50 UTC
After i installed python ports r3.8 then llvm80 and then i want to install xorg it gives smilar error for meson.

i installed meson port than i tried xorg again.



 install  -m 0644 xrandr.pc '/staging/usr/ports/x11/libXrandr/work/stage/usr/local/libdata/pkgconfig'
====> Compressing man pages (compress-man)
===>  Installing for libXrandr-1.5.2
===>  Checking if libXrandr is already installed
===>   Registering installation for libXrandr-1.5.2 as automatic
Installing libXrandr-1.5.2...
===>   mesa-dri-18.3.2_9 depends on file: /usr/local/libdata/pkgconfig/xrandr.pc - found
===>   Returning to build of mesa-dri-18.3.2_9
===>   mesa-dri-18.3.2_9 depends on shared library: libwayland-client.so - found (/usr/local/lib/libwayland-client.so)
===>   mesa-dri-18.3.2_9 depends on shared library: libexpat.so - found (/usr/local/lib/libexpat.so)
===>   mesa-dri-18.3.2_9 depends on shared library: libdrm.so - not found
===>  License MIT accepted by the user
===>   libdrm-2.4.99,1 depends on file: /usr/local/sbin/pkg - found
=> libdrm-2.4.99.tar.bz2 doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch https://dri.freedesktop.org/libdrm/libdrm-2.4.99.tar.bz2
libdrm-2.4.99.tar.bz2                                  833 kB  165 kBps    05s
===> Fetching all distfiles required by libdrm-2.4.99,1 for building
===>  Extracting for libdrm-2.4.99,1
=> SHA256 Checksum OK for libdrm-2.4.99.tar.bz2.
===>  Patching for libdrm-2.4.99,1
===>  Applying extra patch /usr/ports/graphics/libdrm/files/extra-xf86drm.c
===>  Applying FreeBSD patches for libdrm-2.4.99,1
===>   libdrm-2.4.99,1 depends on file: /usr/local/libdata/pkgconfig/pthread-stubs.pc - found
===>   libdrm-2.4.99,1 depends on executable: meson - not found
===>  meson-0.52.1 needs Python 3.5 at least, but 2.7 was specified.
*** Error code 1

Stop.
make[6]: stopped in /usr/ports/devel/meson
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/graphics/libdrm
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/graphics/libdrm
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/graphics/mesa-dri
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/graphics/mesa-dri
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/x11/xorg
*** Error code 1

Stop.
make: stopped in /usr/ports/x11/xorg


 /usr/ports/devel/meson
Comment 2 Jan Beich freebsd_committer 2019-12-27 19:12:59 UTC
See bug 233723 and bug 237795. Workaround: build problematic ports separately.
Comment 3 Niclas Zeising freebsd_committer 2020-04-15 20:06:45 UTC
This was an issue with polluted build environment, and not xorg.