Bug 242925 - x11/xorg: "Xorg -configure" segfaults
Summary: x11/xorg: "Xorg -configure" segfaults
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-27 20:16 UTC by jonathanbusby
Modified: 2020-04-15 20:05 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonathanbusby 2019-12-27 20:16:10 UTC
I'm new to FreeBSD and I've been using a guide to install FreeBSD 12.1 in a VMWare ( latest version of Workstation Pro ) VM running on top of Linux Mint 19.2 Cinnamon 64-bit which is itself running off of an Intel NUC8i7BEH . When I get to the step in the guide which says to issue an "Xorg -configure" command, the command segfaults. I removed the binary package and compiled it within the Ports tree, but, that didn't help.

The problem I'm having seems to be a duplicate of this bug :

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=239568

Note that my install attempt was successful as Xorg created the correct configuration files before segfaulting, but it still seems to be a bug in the Xorg package / Port .

Thanks,

Jonathan
Comment 1 Chris Rees freebsd_committer 2020-01-17 21:31:12 UTC
Have you installed xf86-video-vmware and xf86-input-vmmouse?
Comment 2 Niclas Zeising freebsd_committer 2020-04-15 20:05:42 UTC
Feedback timeout.