Bug 242996 - emulators/wine-devel 5.0-rc1 fails to configure if X11 support is disabled
Summary: emulators/wine-devel 5.0-rc1 fails to configure if X11 support is disabled
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Gerald Pfeifer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-30 23:20 UTC by Patrick McMunn
Modified: 2020-01-04 17:00 UTC (History)
1 user (show)

See Also:


Attachments
Proposed patch (akin to what we arrived at for emulators/wine in two steps) (902 bytes, patch)
2019-12-31 06:22 UTC, Gerald Pfeifer
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick McMunn 2019-12-30 23:20:51 UTC
emulators/wine works just fine, but if I disable X11 support in wine-devel, I get the following error when running "make install clean":

===>  wine-devel-5.0.r1,1 need to specify xorg modules with USE_XORG.
*** Error code 1

Stop.
make: stopped in /usr/ports/emulators/wine-devel
Comment 1 Gerald Pfeifer freebsd_committer 2019-12-31 04:28:02 UTC
Thanks for letting us know!

I believe I know what's going on (and why you only see this for
wine-devel and not the production wine port).

If I am right, this should not be specific to Wine 5.0 RC1, though.
Do you believe it worked for earlier snapshots and it worked or is
this a fresh attempt?
Comment 2 Gerald Pfeifer freebsd_committer 2019-12-31 06:22:28 UTC
Created attachment 210347 [details]
Proposed patch (akin to what we arrived at for emulators/wine in two steps)

Does this patch address the issue you've been seeing?

(I'm still interested in the answers to my questions from earlier today,
just wanted to give it a try and get you unstuck quickly if possible.)
Comment 3 Patrick McMunn 2019-12-31 19:30:48 UTC
I only recently found a use for wine without X11 support, so this is my first time trying to build it with X11 disabled. So it's possible this has been an undiscovered bug for some time. In any case, the proposed patch allowed wine-devel to configure, build, and install successfully with X11 disabled. Thanks for your quick response!
Comment 4 commit-hook freebsd_committer 2020-01-02 06:02:11 UTC
A commit references this bug:

Author: gerald
Date: Thu Jan  2 06:01:57 UTC 2020
New revision: 521798
URL: https://svnweb.freebsd.org/changeset/ports/521798

Log:
  Make sure we employ USES=xorg only when X11/Xorg are actually used,
  much as we have had this for USE_XORG and USE_GL for a while.

  Without this building with option X11 off actually fails now due to
  increased checks in the FreeBSD ports infrastructure.

  PR:		242996
  Reported by:	Patrick McMunn <doctorwhoguy@gmail.com>

Changes:
  head/emulators/wine-devel/Makefile
Comment 5 Gerald Pfeifer freebsd_committer 2020-01-02 06:12:07 UTC
Thanks for the report and the follow-ups.

Per your confirmation of the proposed patch this should be fixed with
what I just committed, so I am closing this report as such.  Please
advise if I missed something and I'll swiftly look into it.
Comment 6 Patrick McMunn 2020-01-04 17:00:47 UTC
Thanks!