Bug 243054 - [NEW PORT] japanese/dams: Geocoder that converts address strings into latitude and longitude
Summary: [NEW PORT] japanese/dams: Geocoder that converts address strings into latitud...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Matthias Andree
URL:
Keywords: feature
Depends on:
Blocks:
 
Reported: 2020-01-03 11:48 UTC by Tomohiro Hosaka
Modified: 2020-05-04 14:32 UTC (History)
2 users (show)

See Also:


Attachments
svn diff (2.68 KB, text/plain)
2020-01-03 11:48 UTC, Tomohiro Hosaka
no flags Details
shar (3.28 KB, text/plain)
2020-01-04 11:08 UTC, Tomohiro Hosaka
no flags Details
shar (3.30 KB, text/plain)
2020-05-01 02:35 UTC, Tomohiro Hosaka
no flags Details
shar (3.28 KB, text/plain)
2020-05-03 14:09 UTC, Tomohiro Hosaka
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomohiro Hosaka 2020-01-03 11:48:24 UTC
* portlint looks fine.
* poudriere testport ok (12.0, amd64, svn-head)
* make test ok
Comment 1 Tomohiro Hosaka 2020-01-03 11:48:26 UTC
Created attachment 210413 [details]
svn diff
Comment 2 Tomohiro Hosaka 2020-01-04 11:08:28 UTC
Created attachment 210439 [details]
shar

-USE_GCC
Comment 3 daniel.engberg.lists 2020-04-30 22:00:27 UTC
Hi,

"make stage-qa" complains about libtool being used but not defined, can you please address that?

https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/uses-libtool.html

Best regards,
Daniel
Comment 4 Tomohiro Hosaka 2020-05-01 02:35:10 UTC
Created attachment 213967 [details]
shar
Comment 5 Tomohiro Hosaka 2020-05-01 02:35:39 UTC
Hi,

Thanks for pointing out.
I confirmed the problem and fixed it.
Comment 6 daniel.engberg.lists 2020-05-02 17:29:04 UTC
pkg-plist doesn't match installed files, you most likely don't want to install lib/libdams.la

====> Running Q/A tests (stage-qa)
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
===> Checking for items in pkg-plist which are not in STAGEDIR
Error: Missing: lib/libdams.la
===> Error: Plist issues found.
*** Error code 1

Stop.
make: stopped in /usr/ports/japanese/dams
=>> Error: check-plist failures detected
build of japanese/dams | ja-dams-4.3.4 ended at Sat May  2 19:24:34 CEST 2020
build time: 00:01:46
!!! build failure encountered !!!
[00:02:08] Error: Build failed in phase: check-plist

Best regards,
Daniel
Comment 7 Tomohiro Hosaka 2020-05-03 14:09:31 UTC
Created attachment 214061 [details]
shar

Thank you for your advice.
I forgot to update the pkg-plist file.
Comment 8 daniel.engberg.lists 2020-05-04 06:14:39 UTC
Hi,

Thanks for updating!
Testport using Poudriere on 12.1-RELEASE (AMD64) now completes successfully.

Best regard,
Daniel
Comment 9 Matthias Andree freebsd_committer 2020-05-04 10:46:51 UTC
Thank you for your contribution!

Next time, please package the directories into the shar as well as the files, that helps with shar extraction.
Comment 10 Matthias Andree freebsd_committer 2020-05-04 11:29:38 UTC
Also, USE_LDCONFIG=yes was needed because this port installs .so files.
Comment 11 commit-hook freebsd_committer 2020-05-04 11:29:39 UTC
A commit references this bug:

Author: mandree
Date: Mon May  4 11:29:20 UTC 2020
New revision: 533921
URL: https://svnweb.freebsd.org/changeset/ports/533921

Log:
  japanese/dams: Geocoder that converts address strings into latitude and longitude

  Geocoder DAMS (Distributed Address Matching System) is software
  that provides a "geocoding" function that converts address strings
  into latitude and longitude.

  WWW: http://newspat.csis.u-tokyo.ac.jp/geocode/

  PR:		243054
  Submitted by:	Tomohiro Hosaka <bokutin@bokut.in>

Changes:
  head/japanese/Makefile
  head/japanese/dams/
  head/japanese/dams/Makefile
  head/japanese/dams/distinfo
  head/japanese/dams/files/
  head/japanese/dams/files/patch-Makefile.in
  head/japanese/dams/files/patch-lib_openfile.cpp
  head/japanese/dams/pkg-descr
  head/japanese/dams/pkg-plist
Comment 12 Tomohiro Hosaka 2020-05-04 13:00:49 UTC
I understood. I will not forget. Thank you.
Comment 13 Matthias Andree freebsd_committer 2020-05-04 13:51:20 UTC
Hello Tomohiro, 

do you happen to know if there is also an English WWW: that we could use?  I have not found one, and there may not be one (which would be fine in my book, for a port under japanese/).

Thank you again!
Comment 14 Tomohiro Hosaka 2020-05-04 14:29:14 UTC
Hello Matthias,

I searched a bit, but I couldn't find any English documentation.

Very simple demo site
https://bokut.in/geo-coder-dams-demo/?q=%E7%A7%8B%E8%91%89%E5%8E%9F

Python binding
https://github.com/hottolink/pydams

Perl binding
https://metacpan.org/pod/Geo::Coder::DAMS
Comment 15 Tomohiro Hosaka 2020-05-04 14:32:48 UTC
{ "score": "3",
   "tail": "",
   "candidates": [
      [
         { "level": "1", "name": "東京都", "x": "139.691635131836", "y": "35.6894989013672" }, <- tokyo-to
         { "level": "3", "name": "台東区", "x": "139.779769897461", "y": "35.7124481201172" }, <- taito-ku
         { "level": "5", "name": "秋葉原", "x": "139.774475097656", "y": "35.702205657959" } <- akihabara
      ]
   ]
}