Bug 243079 - sysutils/vm-bhyve: "start -f" is broken
Summary: sysutils/vm-bhyve: "start -f" is broken
Status: Closed DUPLICATE of bug 240178
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-04 09:01 UTC by Victor Sudakov
Modified: 2020-01-29 03:06 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (churchers)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Sudakov 2020-01-04 09:01:19 UTC
When starting a bhyveload-backed VM with "vm start -f XXX", the last message you see is 
boot/kernel/kernel text=0x1564b08 data=0x145330+0x4cdea0 syms=[0x8+0x16dad8+0x8+0x186a33]
/boot/entropy size=0x1000
Booting...
/

and then silence. 

The VM seems to be running below the event horizon, you can ping or ssh into it. 

Workaround: never use the "start -f" mode, start normally and then use "vm console XXX". 

vm-bhyve-1.3.0 on a FreeBSD 12.1 amd64 host.
Comment 1 churchers 2020-01-14 16:39:51 UTC
This is a duplicate of the same issue in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=240178

Unfortunately it looks like the way we were redirecting error output to file was incredibly ugly and broken, but worked because the way bhyve handling stio was also ugly and incorrect.

This was eventually fixed in bhyve which broke vm-bhyve.

The issue has been fixed in vm-bhyve-1.4.2, which has an open bug report to be committed to ports
Comment 2 Koichiro Iwao freebsd_committer 2020-01-29 03:06:43 UTC

*** This bug has been marked as a duplicate of bug 240178 ***