Bug 243082 - www/qt5-webkit: Will not build
Summary: www/qt5-webkit: Will not build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-04 14:30 UTC by Gerard Seibert
Modified: 2020-01-20 11:26 UTC (History)
1 user (show)

See Also:
tcberner: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerard Seibert 2020-01-04 14:30:59 UTC
FreeBSD 11.3-RELEASE-p5 amd64

I am unable to get the kde5 port to build and install. It always ends with this message:

[173/4448] cd /usr/ports/www/qt5-webkit/work/.build/Source/JavaScriptCore && /usr/local/bin/ruby /usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/offlineasm/generate_offset_extractor.rb -I/usr/ports/www/qt5-webkit/work/.build/DerivedSources/JavaScriptCore/ /usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/llint/LowLevelInterpreter.asm /usr/ports/www/qt5-webkit/work/.build/DerivedSources/JavaScriptCore/LLIntDesiredOffsets.h
[174/4448] /usr/local/libexec/ccache/c++  -DBUILDING_QT__=1 -DBUILDING_WITH_CMAKE=1 -DHAVE_CONFIG_H=1 -DQT_ASCII_CAST_WARNINGS -DQT_CORE_LIB -DQT_DEPRECATED_WARNINGS -DQT_DISABLE_DEPRECATED_BEFORE=0x050000 -DQT_NO_CAST_TO_ASCII -DQT_NO_DEBUG -DQT_NO_DYNAMIC_CAST -DQT_NO_EXCEPTIONS -DQT_USE_QSTRINGBUILDER -DSTATICALLY_LINKED_WITH_WTF -ISource/JavaScriptCore -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore -I. -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/.. -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/API -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/ForwardingHeaders -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/assembler -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/b3 -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/b3/air -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/bindings -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/builtins -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/bytecode -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/bytecompiler -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/dfg -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/disassembler -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/disassembler/udis86 -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/ftl -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/heap -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/debugger -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/inspector -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/inspector/agents -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/inspector/augmentable -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/inspector/remote -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/interpreter -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/jit -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/llint -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/parser -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/profiler -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/replay -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/runtime -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/tools -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/wasm -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/yarr -IDerivedSources -IDerivedSources/ForwardingHeaders -IDerivedSources/JavaScriptCore -IDerivedSources/JavaScriptCore/inspector -I/usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/WTF -isystem /usr/local/include -isystem /usr/local/include/qt5 -isystem /usr/local/include/qt5/QtCore -isystem /usr/local/lib/qt5/mkspecs/freebsd-clang -fvisibility=hidden -fvisibility-inlines-hidden -O2 -pipe -fstack-protector-strong -fno-strict-aliasing  -DNDEBUG -fno-exceptions -fno-strict-aliasing -fno-rtti -std=c++11 -fcolor-diagnostics -Qunused-arguments -O2 -pipe -fstack-protector-strong -fno-strict-aliasing  -DNDEBUG -ffunction-sections -fdata-sections   -fPIC -MD -MT Source/JavaScriptCore/CMakeFiles/LLIntOffsetsExtractor.dir/llint/LLIntOffsetsExtractor.cpp.o -MF Source/JavaScriptCore/CMakeFiles/LLIntOffsetsExtractor.dir/llint/LLIntOffsetsExtractor.cpp.o.d -o Source/JavaScriptCore/CMakeFiles/LLIntOffsetsExtractor.dir/llint/LLIntOffsetsExtractor.cpp.o -c /usr/ports/www/qt5-webkit/work/qtwebkit-5.212.0-alpha3/Source/JavaScriptCore/llint/LLIntOffsetsExtractor.cpp
[175/4448] : && /usr/local/libexec/ccache/c++  -fvisibility=hidden -fvisibility-inlines-hidden -O2 -pipe -fstack-protector-strong -fno-strict-aliasing  -DNDEBUG -fno-exceptions -fno-strict-aliasing -fno-rtti -std=c++11 -fcolor-diagnostics -Qunused-arguments -O2 -pipe -fstack-protector-strong -fno-strict-aliasing  -DNDEBUG -ffunction-sections -fdata-sections  -fstack-protector-strong Source/JavaScriptCore/CMakeFiles/LLIntOffsetsExtractor.dir/llint/LLIntOffsetsExtractor.cpp.o  -o bin/LLIntOffsetsExtractor  -Wl,-rpath,/usr/local/lib:/usr/local/lib/qt5 lib/libWTF.a lib/libbmalloc.a /usr/local/lib/libicui18n.so /usr/local/lib/libicuuc.so /usr/local/lib/qt5/libQt5Core.so.5.13.2 -pthread /usr/local/lib/libgobject-2.0.so /usr/local/lib/libglib-2.0.so && :
FAILED: bin/LLIntOffsetsExtractor 
: && /usr/local/libexec/ccache/c++  -fvisibility=hidden -fvisibility-inlines-hidden -O2 -pipe -fstack-protector-strong -fno-strict-aliasing  -DNDEBUG -fno-exceptions -fno-strict-aliasing -fno-rtti -std=c++11 -fcolor-diagnostics -Qunused-arguments -O2 -pipe -fstack-protector-strong -fno-strict-aliasing  -DNDEBUG -ffunction-sections -fdata-sections  -fstack-protector-strong Source/JavaScriptCore/CMakeFiles/LLIntOffsetsExtractor.dir/llint/LLIntOffsetsExtractor.cpp.o  -o bin/LLIntOffsetsExtractor  -Wl,-rpath,/usr/local/lib:/usr/local/lib/qt5 lib/libWTF.a lib/libbmalloc.a /usr/local/lib/libicui18n.so /usr/local/lib/libicuuc.so /usr/local/lib/qt5/libQt5Core.so.5.13.2 -pthread /usr/local/lib/libgobject-2.0.so /usr/local/lib/libglib-2.0.so && :
/usr/bin/ld:lib/libWTF.a: file format not recognized; treating as linker script
/usr/bin/ld:lib/libWTF.a:1: syntax error
c++: [0;1;31merror: [0mlinker command failed with exit code 1 (use -v to see invocation)[0m
ninja: build stopped: subcommand failed.
*** Error code 1

Stop.
make[10]: stopped in /usr/ports/www/qt5-webkit
*** Error code 1

Stop.
make[9]: stopped in /usr/ports/www/qt5-webkit
*** Error code 1

Stop.
make[8]: stopped in /usr/ports/www/kf5-kdewebkit
*** Error code 1

Stop.
make[7]: stopped in /usr/ports/x11-toolkits/kf5-kdesignerplugin
*** Error code 1

Stop.
make[6]: stopped in /usr/ports/x11/kf5-kdelibs4support
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/sysutils/plasma5-kde-cli-tools
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/x11-fm/dolphin
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/x11-fm/dolphin
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/x11/kde-baseapps
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/x11/kde5
*** Error code 1

Stop.
make: stopped in /usr/ports/x11/kde5

Command exit status: 1

The entire build log is attached.
Comment 1 Tobias C. Berner freebsd_committer 2020-01-04 18:05:25 UTC
Moin moin 

How are you building, and do you have special flags in make.conf?

mfg Tobias
Comment 2 Tobias C. Berner freebsd_committer 2020-01-06 19:21:28 UTC
Moin moin 

I'm unable to reproduce this on Current and 12.1 amd64. 



mfg Tobias
Comment 3 Tobias C. Berner freebsd_committer 2020-01-19 08:05:25 UTC
Moin moin 

Is this still an issue for you?


mfg Tobias
Comment 4 Gerard Seibert 2020-01-20 11:26:40 UTC
(In reply to Tobias C. Berner from comment #3)

No, it seems to have corrected itself.