Bug 243083 - sysutils/lsof: Fix build on 13-CURRENT after base r356337
Summary: sysutils/lsof: Fix build on 13-CURRENT after base r356337
Status: Closed DUPLICATE of bug 243122
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Larry Rosenman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-04 15:10 UTC by Yasuhiro KIMURA
Modified: 2020-01-21 16:47 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (ler)


Attachments
Patch file (756 bytes, patch)
2020-01-04 15:10 UTC, Yasuhiro KIMURA
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro KIMURA 2020-01-04 15:10:24 UTC
Created attachment 210441 [details]
Patch file

Fix build on 13-CURRENT after base r356337.
Comment 1 commit-hook freebsd_committer 2020-01-06 20:42:34 UTC
A commit references this bug:

Author: ler
Date: Mon Jan  6 20:42:09 UTC 2020
New revision: 522273
URL: https://svnweb.freebsd.org/changeset/ports/522273

Log:
  sysutils/lsof: fix build following base r356337.

  I took the patch from 243122 as it was more correct.

  PR:		243122, 243083
  Submitted by:	cy, yasu@utahime.org

Changes:
  head/sysutils/lsof/Makefile
  head/sysutils/lsof/files/patch-dialects_freebsd_dnode2.c
Comment 2 Larry Rosenman freebsd_committer 2020-01-06 20:43:51 UTC

*** This bug has been marked as a duplicate of bug 243122 ***
Comment 3 commit-hook freebsd_committer 2020-01-21 16:47:32 UTC
A commit references this bug:

Author: ler
Date: Tue Jan 21 16:46:44 UTC 2020
New revision: 523728
URL: https://svnweb.freebsd.org/changeset/ports/523728

Log:
  MFH: r522273 r522545 r522582 r523727

  sysutils/lsof: fix build following base r356337.

  I took the patch from 243122 as it was more correct.

  PR:		243122, 243083
  Submitted by:	cy, yasu@utahime.org

  sysutils/lsof: fix after  base r356432.

  PR:		243172
  Submitted by:	mjg
  Reported by:	yasu@utahime.org

  sysutils/lsof: add a PPC64 work around for needing -lzpool

  PR:		242833
  Submitted by:	luciano@vespaperitivo.it

  sysutils/lsof: fix build on powerpc, powerpc64, powerpcse

  PR:		242758
  Submitted by:	pkubaj

  Approved by:	ports-secteam (joneum)

Changes:
_U  branches/2020Q1/
  branches/2020Q1/sysutils/lsof/Makefile
  branches/2020Q1/sysutils/lsof/files/patch-dialects_freebsd_dnode.c
  branches/2020Q1/sysutils/lsof/files/patch-dialects_freebsd_dnode2.c