Bug 243112 - graphics/drm-kmod: g20190710 doesn't recognize HDMI head on RV730 XT [Radeon HD 4670]
Summary: graphics/drm-kmod: g20190710 doesn't recognize HDMI head on RV730 XT [Radeon ...
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: i386 Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-05 11:01 UTC by Zeus Panchenko
Modified: 2020-01-07 09:46 UTC (History)
2 users (show)

See Also:
linimon: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zeus Panchenko 2020-01-05 11:01:45 UTC
graphics/drm-kmod-g20190710 doesn't recognize HDMI head on RV730 XT Radeon HD 4670 (xrandr reports HDMI as disconnected)

while graphics/drm-legacy-kmod-g20191217 works fine

> uname -a
12.1-RELEASE-p1

> pciconf -lv
vgapci0@pci0:2:0:0:	class=0x030000 card=0x02761043 chip=0x94901002 rev=0x00 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD/ATI]'
    device     = 'RV730 XT [Radeon HD 4670]'
    class      = display
    subclass   = VGA
Comment 1 Niclas Zeising freebsd_committer 2020-01-07 09:05:25 UTC
graphics/drm-kmod is just a meta-port that pulls in the correct drm-*-kmod, can you list the version of the installed drm-fbsd12.0-kmod please?
Comment 2 Zeus Panchenko 2020-01-07 09:46:17 UTC
drm-fbsd12.0-kmod-4.16.g20191120

as well as all variants of ports in head

in addition, I've checked it on 13.0-CURRENT and ports head, so, all variants except legacy behave the same - after drm initialization, HDMI display blanks (though, it doesn't show "No signal" message in that state)