Bug 243115 - [NEW PORT] graphics/pastel: Command-line tool to generate, analyze, convert and manipulate colors
Summary: [NEW PORT] graphics/pastel: Command-line tool to generate, analyze, convert a...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitri Goutnik
URL: https://github.com/sharkdp/pastel
Keywords: feature
Depends on:
Blocks:
 
Reported: 2020-01-05 14:20 UTC by Lewis Cook
Modified: 2020-03-01 13:30 UTC (History)
1 user (show)

See Also:


Attachments
pastel-0.6.1.diff (12.64 KB, patch)
2020-01-05 14:20 UTC, Lewis Cook
no flags Details | Diff
pastel-0.6.1.log (49.04 KB, text/plain)
2020-01-11 11:12 UTC, Lewis Cook
no flags Details
pastel-0.7.0.diff (22.35 KB, patch)
2020-02-27 19:19 UTC, Lewis Cook
no flags Details | Diff
pastel-0.7.0.log (83.29 KB, text/plain)
2020-02-27 19:20 UTC, Lewis Cook
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lewis Cook 2020-01-05 14:20:21 UTC
Created attachment 210467 [details]
pastel-0.6.1.diff

Command-line tool to generate, analyze, convert
and manipulate colors. It supports many different
color formats and color spaces like RGB (sRGB),
HSL, CIELAB, CIELCh as well as ANSI 8-bit and
24-bit representations.

WWW: https://github.com/sharkdp/pastel

QA:
  * portlint: Looks fine;
  * poudriere: package built, application works as intended.
Comment 1 Lewis Cook 2020-01-11 11:12:09 UTC
Created attachment 210615 [details]
pastel-0.6.1.log

* Poudriere build log.
Comment 2 Lewis Cook 2020-02-27 19:19:58 UTC
Created attachment 212005 [details]
pastel-0.7.0.diff

Update to 0.7.0.
Comment 3 Lewis Cook 2020-02-27 19:20:25 UTC
Created attachment 212006 [details]
pastel-0.7.0.log

* Poudriere build log.
Comment 4 commit-hook freebsd_committer 2020-03-01 13:29:38 UTC
A commit references this bug:

Author: dmgk
Date: Sun Mar  1 13:29:32 UTC 2020
New revision: 527553
URL: https://svnweb.freebsd.org/changeset/ports/527553

Log:
  New port: graphics/pastel

  Command-line tool to generate, analyze, convert
  and manipulate colors. It supports many different
  color formats and color spaces like RGB (sRGB),
  HSL, CIELAB, CIELCh as well as ANSI 8-bit and
  24-bit representations.

  WWW: https://github.com/sharkdp/pastel

  PR:		243115
  Submitted by:	Lewis Cook <vulcan@wired.sh>

Changes:
  head/graphics/Makefile
  head/graphics/pastel/
  head/graphics/pastel/Makefile
  head/graphics/pastel/distinfo
  head/graphics/pastel/pkg-descr
Comment 5 Dmitri Goutnik freebsd_committer 2020-03-01 13:30:24 UTC
Committed, thanks!