Bug 243165 - java/openjdk8: fails to build in poudriere with recent head (r356422)
Summary: java/openjdk8: fails to build in poudriere with recent head (r356422)
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-java mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-07 19:04 UTC by Guido Falsi
Modified: 2020-01-08 09:59 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (java)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Falsi freebsd_committer 2020-01-07 19:04:24 UTC
Hi,

I've recently updated my machines to head r356422, and was rebuilding my package sets. I got a failure with openjdk8, it seems to not like the provided bootstrap, I'm not sure how to address this, anyone can help?

Meybe a newer bootstrap is required?

Here's the relevant part from the build log:

checking for 7z... no
checking for unzip... unzip
checking for wget... no
checking for lftp... no
checking for ftp... ftp
checking headful support... include support for both headful and headless
configure: Found potential Boot JDK using configure arguments
configure: Potential Boot JDK found at /usr/local/bootstrap-openjdk8 is incorrect JDK version (); ignoring
configure: (Your Boot JDK must be version 7 or 8)
configure: error: The path given by --with-boot-jdk does not contain a valid Boot JDK
configure exiting with result code 1
===>  Script "../../configure" failed unexpectedly.
Please report the problem to java@FreeBSD.org [maintainer] and attach the
"/wrkdirs/usr/ports/java/openjdk8/work/openjdk-jdk8u-jdk8u232-b09.1/common/autoconf/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/java/openjdk8
=>> Cleaning up wrkdir
===>  Cleaning for openjdk8-8.232.09.1_1
Comment 1 Guido Falsi freebsd_committer 2020-01-07 19:05:32 UTC
Adding jkim to the CC list, since he's the maintainer of the bootstrap port.

Thanks in advance for any help.
Comment 2 Guido Falsi freebsd_committer 2020-01-07 20:43:40 UTC
In bug 243157, regarding an apparently unrelated issue with lang/rust, it's been pointed out that rust requires COMPAT_* options in the kernel for the bootstrap to work.

Maybe this bug is caused by the same absence, I'll report back after testing.
Comment 3 Guido Falsi freebsd_committer 2020-01-08 09:59:55 UTC
I confirm that adding back COMPAT_* options in the kernel, makes the problem go away, so this was my error.

Sorry for the noise.