Bug 243175 - Several ports pkgs require clang-9.0.1 to build properly but cc on 11.3-stable is clang-8.0.1
Summary: Several ports pkgs require clang-9.0.1 to build properly but cc on 11.3-stabl...
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 11.3-STABLE
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-08 07:29 UTC by jau
Modified: 2020-02-21 12:04 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jau 2020-01-08 07:29:30 UTC
Several ports pkgs need clang-9.0.1 to build properly but cc on 11.3-stable is clang-8.0.1.
Either the ports pkgs (e.g. gdal, ffmpeg, ...) should be changed to explicitly
require clang90 or 11.3 base system should be upgraded to use clang-9.0.1 by
default.
Comment 1 Ed Maste freebsd_committer 2020-02-12 23:02:01 UTC
It's not possible to change the compiler in 11.3 as it is already released. If ports are broken on 11.3 due to Clang 8.0.1 they need to depend on the Clang port/package.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-21 12:04:34 UTC
Thank you for your report. For any ports that fail to build on any supported FreeBSD versions (11.3 for example), please create reports for each individual port, if they haven't been reported already (search first please)

Each port report should be prefixed with "$category/$portname" of the port in question