Bug 243184 - textproc/py-sphinx@py37: Fails to build: struct.error: unpack requires a buffer of 44 bytes
Summary: textproc/py-sphinx@py37: Fails to build: struct.error: unpack requires a buff...
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kubilay Kocak
URL:
Keywords:
: 243217 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-08 12:22 UTC by O. Hartmann
Modified: 2020-01-14 05:50 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2020-01-08 12:22:26 UTC
[...]
===>  Patching for py37-sphinx-1.6.5_2,1
===>  Applying FreeBSD patches for py37-sphinx-1.6.5_2,1
===>   py37-sphinx-1.6.5_2,1 depends on package: py37-Jinja2>=2.3 - found
===>   py37-sphinx-1.6.5_2,1 depends on package: py37-docutils>=0.11 - found
===>   py37-sphinx-1.6.5_2,1 depends on package: py37-six>=1.4 - found
===>   py37-sphinx-1.6.5_2,1 depends on package: py37-setuptools>0 - found
===>   py37-sphinx-1.6.5_2,1 depends on file: /usr/local/bin/python3.7 - found
===>  Configuring for py37-sphinx-1.6.5_2,1
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "setup.py", line 91, in <module>
    from babel.messages.pofile import read_po
  File "/usr/local/lib/python3.7/site-packages/babel/messages/__init__.py", line 12, in <module>
    from babel.messages.catalog import *
  File "/usr/local/lib/python3.7/site-packages/babel/messages/catalog.py", line 24, in <module>
    from babel.dates import format_datetime
  File "/usr/local/lib/python3.7/site-packages/babel/dates.py", line 29, in <module>
    from babel.util import UTC, LOCALTZ
  File "/usr/local/lib/python3.7/site-packages/babel/util.py", line 20, in <module>
    from babel import localtime
  File "/usr/local/lib/python3.7/site-packages/babel/localtime/__init__.py", line 74, in <module>
    LOCALTZ = get_localzone()
  File "/usr/local/lib/python3.7/site-packages/babel/localtime/__init__.py", line 70, in get_localzone
    return _get_localzone()
  File "/usr/local/lib/python3.7/site-packages/babel/localtime/_unix.py", line 126, in _get_localzone
    return pytz.tzfile.build_tzinfo('local', tzfile)
  File "/usr/local/lib/python3.7/site-packages/pytz/tzfile.py", line 29, in build_tzinfo
    typecnt, charcnt) = unpack(head_fmt, fp.read(head_size))
struct.error: unpack requires a buffer of 44 bytes
*** Error code 1

Stop.
make: stopped in /usr/ports/textproc/py-sphinx

===>>> make build failed for textproc/py-sphinx@py37
===>>> Aborting update
Comment 1 O. Hartmann 2020-01-08 12:26:01 UTC
Fingers were too fast ...

The error shown popped up today after a recent upgrade of the CURRENT host running FreeBSD 13.0-CURRENT #28 r356483: Wed Jan  8 09:29:49 UTC 2020  amd64. The ports tree has been updated recently, the migration from python 3.6 to 3.7 has been performed recently, too.

Tried to recompile lang/python|lang/python3|lang/python37 via "portmaster -dRf" to ensure I've on the most recent track for the python 3.7 suite. but it didn't help.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-01-11 11:32:51 UTC
*** Bug 243217 has been marked as a duplicate of this bug. ***
Comment 3 O. Hartmann 2020-01-14 05:44:06 UTC
Setting localtime via tzsetup solved obviously the problem. Thank you very much for the hint.
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2020-01-14 05:50:32 UTC
(In reply to O. Hartmann from comment #3)

This feels like behaviour that could (should?) be improved in pytz. Might be worthwhile opening an issue, if one hasn't been already to get advice on that front