Bug 243217 - textproc/py-sphinx: compile error: struct.error: unpack requires a buffer of 44 bytes
Summary: textproc/py-sphinx: compile error: struct.error: unpack requires a buffer of ...
Status: Closed DUPLICATE of bug 243184
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-python mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-09 12:56 UTC by O. Hartmann
Modified: 2020-01-11 11:32 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (python)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2020-01-09 12:56:57 UTC
This bug haunts me on one single box and I can not fathom what the cause might be. Almost every port has been recompiled by now. The base system ist running CURRENT (13.0-CURRENT #30 r356540: Thu Jan  9 06:11:52 UTC 2020).

The transition from Python 3.6 to 3.7 has already been performed. Any ideas?

[...]
===>  Configuring for py37-sphinx-1.6.5_2,1
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "setup.py", line 91, in <module>
    from babel.messages.pofile import read_po
  File "/usr/local/lib/python3.7/site-packages/babel/messages/__init__.py", line 12, in <module>
    from babel.messages.catalog import *
  File "/usr/local/lib/python3.7/site-packages/babel/messages/catalog.py", line 24, in <module>
    from babel.dates import format_datetime
  File "/usr/local/lib/python3.7/site-packages/babel/dates.py", line 29, in <module>
    from babel.util import UTC, LOCALTZ
  File "/usr/local/lib/python3.7/site-packages/babel/util.py", line 20, in <module>
    from babel import localtime
  File "/usr/local/lib/python3.7/site-packages/babel/localtime/__init__.py", line 74, in <module>
    LOCALTZ = get_localzone()
  File "/usr/local/lib/python3.7/site-packages/babel/localtime/__init__.py", line 70, in get_localzone
    return _get_localzone()
  File "/usr/local/lib/python3.7/site-packages/babel/localtime/_unix.py", line 126, in _get_localzone
    return pytz.tzfile.build_tzinfo('local', tzfile)
  File "/usr/local/lib/python3.7/site-packages/pytz/tzfile.py", line 29, in build_tzinfo
    typecnt, charcnt) = unpack(head_fmt, fp.read(head_size))
struct.error: unpack requires a buffer of 44 bytes
*** Error code 1

Stop.
make: stopped in /usr/ports/textproc/py-sphinx
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-01-11 11:32:51 UTC

*** This bug has been marked as a duplicate of bug 243184 ***