Bug 243247 - biology/infernal: Update to 1.1.3
Summary: biology/infernal: Update to 1.1.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Fernando Apesteguía
URL:
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2020-01-10 14:25 UTC by Motomichi Matsuzaki
Modified: 2020-01-28 07:06 UTC (History)
2 users (show)

See Also:
mzaki: maintainer-feedback+


Attachments
svn diff for biology/infernal to 1.1.3 (4.62 KB, patch)
2020-01-10 14:25 UTC, Motomichi Matsuzaki
no flags Details | Diff
diff for testing (1.93 KB, patch)
2020-01-16 02:37 UTC, Motomichi Matsuzaki
no flags Details | Diff
svn diff for biology/infernal to 1.1.3 (revised) (5.64 KB, patch)
2020-01-27 09:56 UTC, Motomichi Matsuzaki
mzaki: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Motomichi Matsuzaki 2020-01-10 14:25:00 UTC
Created attachment 210595 [details]
svn diff for biology/infernal to 1.1.3

Update biology/infernal to 1.1.3

*'make test' now requires python3
*Makefile sync'ed with biology/hmmer (bug #243244)

please note that the MAINTAINER mail address is modified.

The port passed poudriere testport in my environment (11.3 amd64/i386).
Comment 1 Automation User 2020-01-10 14:51:14 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/108425851
Comment 2 Fernando Apesteguía freebsd_committer 2020-01-13 17:32:02 UTC
Hi Motomichi,

Thanks for the patch.

I noticed that 3 tests fail. Is this a known issue?

...
...
    exercise  297 [           hmmpgmd_ga] ...     FAILED [command failed]
    exercise  298 [               rewind] ...     ok.
    exercise  299 [     hmmpgmd_shard_ga] ...     FAILED [command failed]
    exercise  300 [            bad-fasta] ...     ok.
    exercise  301 [          brute-itest] ...     ok.
    exercise  302 [       hmmpress-itest] ...     ok.
    exercise  303 [                  h39] ...     ok.
    exercise  304 [                  h45] ...     ok.
    exercise  305 [                  h50] ...     ok.
    exercise  306 [                  h82] ...     ok.
    exercise  307 [               iss159] ...     FAILED [command failed]
Comment 3 Motomichi Matsuzaki 2020-01-14 04:56:34 UTC
(In reply to Fernando Apesteguía from comment #2)

I have never seen these fails in my environment.
The tests can be performed separately after build as follows:

% cd ${WRKSRC}/hmmer/testsuite
% ./i19-hmmpgmd-ga.pl .. .. tmppfx
% ./i22-hmmpgmd-shard-ga.pl .. .. tmpprx
% ./iss159-nhmmer-overlap.py .. .. tmppfx

These would emit (a little) detailed error messages upon fails.
Comment 4 Fernando Apesteguía freebsd_committer 2020-01-15 17:21:58 UTC
(In reply to Motomichi Matsuzaki from comment #3)

$ cd work/infernal-1.1.3/hmmer/testsuite/
$ ./i19-hmmpgmd-ga.pl 
$ FAIL: didn't find hmmpgmd executable in /src

Any special setup needed?
Comment 5 Fernando Apesteguía freebsd_committer 2020-01-15 17:34:02 UTC
Sorry, my bad. Here are the test executions:

$ ./i19-hmmpgmd-ga.pl .. .. tmppfx
FAIL: hmmc2 returned non-zero exit code of 256 at ./i19-hmmpgmd-ga.pl line 107.

$ ./iss159-nhmmer-overlap.py .. .. tmppfx
FAIL: hmmbuild failed

./i22-hmmpgmd-shard-ga.pl  .. .. tmppfx
FAIL: hmmc2 returned non-zero exit code of 256 at ./i22-hmmpgmd-shard-ga.pl line 89.
Comment 6 Motomichi Matsuzaki 2020-01-16 02:37:21 UTC
Created attachment 210784 [details]
diff for testing

i19 & i22 could be network-related problems.
as for iss159, I have no idea.

Could you please apply the patch to obtain directly the error messages?

% make clean; make
% cd ${WRKSRC}/hmmer/testsuite
% patch <patch.diff
% ./i19-hmmpgmd-ga.pl .. .. tmppfx
% ./i22-hmmpgmd-shard-ga.pl .. .. tmppfx
% ./iss159-nhmmer-overlap.py .. .. tmppfx
Comment 7 Fernando Apesteguía freebsd_committer 2020-01-17 16:23:36 UTC
FWIW, I tried on a different computer and the same tests fail.

Also, 1.1.2 seems to work: 

./i19-hmmpgmd-ga.pl .. .. tmppfx
ok

It seems a regression in the new version.
Comment 8 Motomichi Matsuzaki 2020-01-27 09:56:38 UTC
Created attachment 211100 [details]
svn diff for biology/infernal to 1.1.3 (revised)

a revised patch to pass "make test" in 13-CURRENT
Comment 9 Motomichi Matsuzaki 2020-01-27 10:04:31 UTC
(In reply to Fernando Apesteguía from comment #7)

Now I have reproduced the problem.
The fail in iss159 is dependent on previous fails (hmmpgmd_ga & hmmpgmd_shard_ga),
and there is no problems in iss159 itself.
The fails in hmmpgmd_ga & hmmpgmd_shard_ga are caused by the binary hmm2c,
which has hardcoded errno in its shutdown process.

The revised patch is tested on 13-CURRENT & 11.3R (both amd64),
and "make test" successed cleanly.
Comment 10 commit-hook freebsd_committer 2020-01-27 17:58:10 UTC
A commit references this bug:

Author: fernape
Date: Mon Jan 27 17:57:15 UTC 2020
New revision: 524268
URL: https://svnweb.freebsd.org/changeset/ports/524268

Log:
  biology/infernal: update to 1.1.3

  PR:     243247
  Submitted by:   mzaki@e-mail.ne.jp (maintainer)

Changes:
  head/biology/infernal/Makefile
  head/biology/infernal/distinfo
  head/biology/infernal/files/patch-configure
  head/biology/infernal/files/patch-hmmer_src_hmmc2.c
  head/biology/infernal/files/patch-src_Makefile.in
Comment 11 Fernando Apesteguía freebsd_committer 2020-01-27 18:01:25 UTC
Committed,

Thanks!
Comment 12 Motomichi Matsuzaki 2020-01-28 02:20:35 UTC
(In reply to Fernando Apesteguía from comment #11)

Thanks so much.

Could you handle Bug #243244 too?
It comes from the same author, and has quite similar structure.
(In fact, Infernal 1.1.3 contains a whole package of Hmmer 3.3)
Comment 13 Fernando Apesteguía freebsd_committer 2020-01-28 07:06:21 UTC
(In reply to Motomichi Matsuzaki from comment #12)

Sure!