Bug 243260 - java/openjdk11: fails to build on ARCH=aarch64
Summary: java/openjdk11: fails to build on ARCH=aarch64
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-java mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-11 02:38 UTC by Jonathan Chen
Modified: 2020-01-11 02:55 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (java)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Chen 2020-01-11 02:38:45 UTC
I'm attempt to crossbuild openjdk-11 for ARCH=aarch64, but the build is currently failing when it checks the bootstrap:

...
checking if packaged modules are kept... yes (default)
checking for version string... 11.0.5+10-1
configure: Found potential Boot JDK using configure arguments
configure: Potential Boot JDK found at /usr/local/bootstrap-openjdk11 is incorre
ct JDK version (#); ignoring
configure: (Your Boot JDK version must be one of: 10 11)
configure: error: The path given by --with-boot-jdk does not contain a valid Boo
t JDK
configure exiting with result code 1
===>  Script "configure" failed unexpectedly.
Please report the problem to java@FreeBSD.org [maintainer] and attach the
"/construction/xports/java/openjdk11/work/openjdk-jdk11u-jdk-11.0.5-10-1/config.
log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
Comment 1 Jonathan Chen 2020-01-11 02:55:37 UTC
Looks like a problem with qemu-aarch64-static instead. The bootstrap-java binary fails with SIGILL on the crossbuild host, but succeeds an a native RPI3 host.