Bug 243274 - graphics/ilmbase: package error in poudriere (pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libHalf-2_4.so:No such file or directory)
Summary: graphics/ilmbase: package error in poudriere (pkg-static: Unable to access fi...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Matthias Andree
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-11 17:32 UTC by Marcin Cieślak
Modified: 2020-01-11 19:48 UTC (History)
0 users

See Also:
mandree: maintainer-feedback+


Attachments
poudriere log (76.88 KB, text/plain)
2020-01-11 17:33 UTC, Marcin Cieślak
no flags Details
my own build log (79.62 KB, text/plain)
2020-01-11 18:45 UTC, Matthias Andree
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Cieślak 2020-01-11 17:32:01 UTC
Poudriere run in in 11.3-RELEASE-p4 amd64 jail with ports updated:


Updating from Sat Jan 11 11:29:24 UTC 2020 to Sat Jan 11 16:38:27 UTC 2020.


====> Compressing man pages (compress-man)
===========================================================================
=======================<phase: package        >============================
===>  Building package for ilmbase-2.4.0
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libHalf-2_4.so:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libHalf-2_4.so.24:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libHalf-2_4.so.24.0.0:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libIex-2_4.so:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libIex-2_4.so.24:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libIex-2_4.so.24.0.0:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libIexMath-2_4.so:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libIexMath-2_4.so.24:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libIexMath-2_4.so.24.0.0:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libIlmThread-2_4.so:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libIlmThread-2_4.so.24:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libIlmThread-2_4.so.24.0.0:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libImath-2_4.so:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libImath-2_4.so.24:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libImath-2_4.so.24.0.0:No such file or directory
*** Error code 1

Stop.
make: stopped in /usr/ports/graphics/ilmbase
=>> Cleaning up wrkdir
===>  Cleaning for ilmbase-2.4.0
build of graphics/ilmbase | ilmbase-2.4.0 ended at Sat Jan 11 17:06:50 UTC 2020
build time: 00:05:11
!!! build failure encountered !!!
Comment 1 Marcin Cieślak 2020-01-11 17:33:21 UTC
Created attachment 210627 [details]
poudriere log

Attached log from poudriere
Comment 2 Matthias Andree freebsd_committer 2020-01-11 18:45:54 UTC
Created attachment 210629 [details]
my own build log

This is my build log; as you can see, the build was successful.
Comment 3 Marcin Cieślak 2020-01-11 19:01:04 UTC
Thanks! can you try WITH_DEBUG=yes ? (Looks like I am getting the "Debug" cmake profile).

===>   Generating temporary packing list
-[0/1] cd /wrkdirs/usr/ports/graphics/ilmbase/work/.build && /usr/local/bin/cmake -P cmake_install.cmake
--- Install configuration: "Debug"
+[0/1] cd /wrkdirs/usr/ports/graphics/ilmbase/work/.build && /usr/local/bin/cmake -DCMAKE_INSTALL_DO_STRIP=1 -P cmake_insta
ll.cmake
+-- Install configuration: "Release"
 -- Installing: /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/include/OpenEXR/IlmBaseConfig.h
 -- Installing: /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/pkgconfig/IlmBase.pc
 -- Installing: /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/cmake/IlmBase/IlmBaseConfigVersion.cmake
 -- Installing: /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/cmake/IlmBase/IlmBaseConfig.cmake
--- Installing: /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/cmake/IlmBase/IlmBaseConfig-debug.cmake
--- Installing: /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libHalf-2_4_d.so.24.0.0
--- Installing: /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libHalf-2_4_d.so.24
--- Set runtime path of "/wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libHalf-2_4_d.so.24.0.0" to "/usr/loc
al/lib"
--- Installing: /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libHalf-2_4_d.so
+-- Installing: /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/cmake/IlmBase/IlmBaseConfig-release.cmake
+-- Installing: /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libHalf-2_4.so.24.0.0
+-- Installing: /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libHalf-2_4.so.24
+-- Set runtime path of "/wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libHalf-2_4.so.24.0.0" to "/usr/local
/lib"
+-- Installing: /wrkdirs/usr/ports/graphics/ilmbase/work/stage/usr/local/lib/libHalf-2_4.so
Comment 4 Matthias Andree freebsd_committer 2020-01-11 19:02:48 UTC
oh heck, under WITH_DEBUG=yes it renames its libs to include _d names. Thanks for pointing that out.

WITH_DEBUG=yes reproduces:
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: lib/libHalf-%%MAJORVER%%_d.so
Error: Orphaned: lib/libHalf-%%MAJORVER%%_d.so.24
Error: Orphaned: lib/libHalf-%%MAJORVER%%_d.so.24.0.0
Error: Orphaned: lib/libIex-%%MAJORVER%%_d.so
Error: Orphaned: lib/libIex-%%MAJORVER%%_d.so.24
Error: Orphaned: lib/libIex-%%MAJORVER%%_d.so.24.0.0
Error: Orphaned: lib/libIexMath-%%MAJORVER%%_d.so
Error: Orphaned: lib/libIexMath-%%MAJORVER%%_d.so.24
Error: Orphaned: lib/libIexMath-%%MAJORVER%%_d.so.24.0.0
Error: Orphaned: lib/libIlmThread-%%MAJORVER%%_d.so
Error: Orphaned: lib/libIlmThread-%%MAJORVER%%_d.so.24
Error: Orphaned: lib/libIlmThread-%%MAJORVER%%_d.so.24.0.0
Error: Orphaned: lib/libImath-%%MAJORVER%%_d.so
Error: Orphaned: lib/libImath-%%MAJORVER%%_d.so.24
Error: Orphaned: lib/libImath-%%MAJORVER%%_d.so.24.0.0
===> Checking for items in pkg-plist which are not in STAGEDIR
Error: Missing: lib/libHalf-%%MAJORVER%%.so
Error: Missing: lib/libHalf-%%MAJORVER%%.so.24
Error: Missing: lib/libHalf-%%MAJORVER%%.so.24.0.0
Error: Missing: lib/libIex-%%MAJORVER%%.so
Error: Missing: lib/libIex-%%MAJORVER%%.so.24
Error: Missing: lib/libIex-%%MAJORVER%%.so.24.0.0
Error: Missing: lib/libIexMath-%%MAJORVER%%.so
Error: Missing: lib/libIexMath-%%MAJORVER%%.so.24
Error: Missing: lib/libIexMath-%%MAJORVER%%.so.24.0.0
Error: Missing: lib/libIlmThread-%%MAJORVER%%.so
Error: Missing: lib/libIlmThread-%%MAJORVER%%.so.24
Error: Missing: lib/libIlmThread-%%MAJORVER%%.so.24.0.0
Error: Missing: lib/libImath-%%MAJORVER%%.so
Error: Missing: lib/libImath-%%MAJORVER%%.so.24
Error: Missing: lib/libImath-%%MAJORVER%%.so.24.0.0
===> Error: Plist issues found.
Comment 5 Marcin Cieślak 2020-01-11 19:04:49 UTC
And I just realized I had both WITH_DEBUG=yes and WITH_DEBUG_PORTS set.

It's a win-win here :)
Comment 6 Marcin Cieślak 2020-01-11 19:06:09 UTC
It packages again after I have removed WITH_DEBUG=yes, so this was it, thanks!
Comment 7 Matthias Andree freebsd_committer 2020-01-11 19:10:18 UTC
r522706 should fix WITH_DEBUG=yes builds, and assorted other stuff.
Comment 8 commit-hook freebsd_committer 2020-01-11 19:10:27 UTC
A commit references this bug:

Author: mandree
Date: Sat Jan 11 19:10:00 UTC 2020
New revision: 522706
URL: https://svnweb.freebsd.org/changeset/ports/522706

Log:
  Minor build fixes, includes WITH_DEBUG builds

  - under WITH_DEBUG=yes builds, avoid renaming the libraries with _d suffix.
    (else it breaks packaging, and we don't want separate lib names) [1]
  - while here, avoid creating symlinks from cmake, this causes staging
    violations due to cmake bug #17340, (poudriere testport)
    see https://gitlab.kitware.com/cmake/cmake/issues/17340
  - while here, fix "make test" target - it is a left over from 2.3's
    gmake build. Use ctest instead.

  No PORTREVISION bump necessary because each and every fixed bug would
  cause a broken build and no install.

  PR:		243274 [1]
  Reported by:	Marcin Cie?lak [1]

Changes:
  head/graphics/ilmbase/Makefile
  head/graphics/ilmbase/files/patch-CMakeLists.txt
  head/graphics/ilmbase/files/patch-config_CMakeLists.txt
  head/graphics/ilmbase/files/patch-config_IlmBaseSetup.cmake
  head/graphics/ilmbase/files/patch-config_LibraryDefine.cmake
Comment 9 commit-hook freebsd_committer 2020-01-11 19:18:28 UTC
A commit references this bug:

Author: mandree
Date: Sat Jan 11 19:17:38 UTC 2020
New revision: 522707
URL: https://svnweb.freebsd.org/changeset/ports/522707

Log:
  Port ilmbase build fixes including WITH_DEBUG=yes builds.

  - under WITH_DEBUG=yes builds, avoid renaming the libraries with _d suffix.
    (else it breaks packaging, and we don't want separate lib names) [1]
  - while here, avoid creating symlinks from cmake, this causes staging
    violations due to cmake bug #17340, (poudriere testport)
    see https://gitlab.kitware.com/cmake/cmake/issues/17340
  - while here, fix "make test" target - it is a left over from 2.3's
    gmake build. Use ctest instead. Removes TEST_TARGET.

  No PORTREVISION bump necessary because each and every fixed bug would
  cause a broken build and no install.

  PR:		243274 [1]
  Reported by:	Marcin Cieslak [1] against graphics/ilmbase

Changes:
  head/graphics/openexr/Makefile
  head/graphics/openexr/files/patch-config_LibraryDefine.cmake
  head/graphics/openexr/files/patch-config_OpenEXRSetup.cmake
Comment 10 Matthias Andree freebsd_committer 2020-01-11 19:18:43 UTC
I also needed to fix openexr, which has now happened.

Thanks for your report, and sorry for the premature closing on the first attempt.
Comment 11 Marcin Cieślak 2020-01-11 19:48:47 UTC
No problem. Thank for responding so fast.

I have simply diffed our poudriere logs and apart from ccache this looked like the only difference to me.

It is not my first WITH_DEBUG problem today ... (the other being https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242053)