Bug 243301 - www/firefox: 72.0.1: Segmentation fault
Summary: www/firefox: 72.0.1: Segmentation fault
Status: Closed DUPLICATE of bug 243252
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-gecko mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-12 20:55 UTC by iron.udjin
Modified: 2020-01-13 05:52 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gecko)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description iron.udjin 2020-01-12 20:55:39 UTC
Hello,

I run firefox-72.0.1_1,1 on FreeBSD 12.1-STABLE r356482. When I'm trying to start it I'm getting Segmentation fault:

Assertion failure: !locale.IsEmpty(), at /usr/ports/www/firefox/work/firefox-72.0.1/intl/locale/LocaleService.cpp:415
#01: void std::__1::__tree_balance_after_insert<std::__1::__tree_node_base<void*>*>(void*, std::__1::__tree_balance_after_insert<std::__1::__tree_node_base<void*>*>)[/usr/local/lib/firefox/libxul.so +0x4aa8161]
#02: void std::__1::__tree_balance_after_insert<std::__1::__tree_node_base<void*>*>(void*, std::__1::__tree_balance_after_insert<std::__1::__tree_node_base<void*>*>)[/usr/local/lib/firefox/libxul.so +0x4aaa99d]
#03: void std::__1::__tree_balance_after_insert<std::__1::__tree_node_base<void*>*>(void*, std::__1::__tree_balance_after_insert<std::__1::__tree_node_base<void*>*>)[/usr/local/lib/firefox/libxul.so +0x4aaabdd]
#04: _ZNSt3__16vectorINS_12basic_stringIcNS_11char_traitsIcEENS_9allocatorIcEEEENS4_IS6_EEE21__push_back_slow_pathIS6_EEvOT_[/usr/local/lib/firefox/libxul.so +0x4a386f1]
#05: _ZNSt3__16vectorINS_12basic_stringIcNS_11char_traitsIcEENS_9allocatorIcEEEENS4_IS6_EEE21__push_back_slow_pathIS6_EEvOT_[/usr/local/lib/firefox/libxul.so +0x4a3920a]
#06: std::__1::basic_stringbuf<char, std::__1::char_traits<char>, std::__1::allocator<char> >::str(void) const[/usr/local/lib/firefox/libxul.so +0x49d7f6c]
#07: std::__1::basic_stringbuf<char, std::__1::char_traits<char>, std::__1::allocator<char> >::str(void) const[/usr/local/lib/firefox/libxul.so +0x49df156]
#08: std::__1::basic_stringbuf<char, std::__1::char_traits<char>, std::__1::allocator<char> >::str(void) const[/usr/local/lib/firefox/libxul.so +0x49df1e3]
#09: std::__1::basic_stringbuf<char, std::__1::char_traits<char>, std::__1::allocator<char> >::str(void) const[/usr/local/lib/firefox/libxul.so +0x49d8011]
#10: std::__1::basic_stringbuf<char, std::__1::char_traits<char>, std::__1::allocator<char> >::str(void) const[/usr/local/lib/firefox/libxul.so +0x49df156]
#11: std::__1::basic_stringbuf<char, std::__1::char_traits<char>, std::__1::allocator<char> >::str(void) const[/usr/local/lib/firefox/libxul.so +0x49de59d]
#12: std::__1::basic_stringbuf<char, std::__1::char_traits<char>, std::__1::allocator<char> >::str(void) const[/usr/local/lib/firefox/libxul.so +0x49dd9ce]
#13: _ZNSt3__16vectorINS_12basic_stringIcNS_11char_traitsIcEENS_9allocatorIcEEEENS4_IS6_EEE21__push_back_slow_pathIS6_EEvOT_[/usr/local/lib/firefox/libxul.so +0x4a4650b]
#14: std::__1::operator>><char, std::__1::char_traits<char>, std::__1::allocator<char> >(std::__1::basic_istream<char, std::__1::char_traits<char>>&, std::__1::basic_istream<char, std::__1::char_traits<char>>&, std::__1::basic_string<std::__1::basic_istream, c[/usr/local/lib/firefox/libxul.so +0x986dae2]
#15: std::__1::operator>><char, std::__1::char_traits<char>, std::__1::allocator<char> >(std::__1::basic_istream<char, std::__1::char_traits<char>>&, std::__1::basic_istream<char, std::__1::char_traits<char>>&, std::__1::basic_string<std::__1::basic_istream, c[/usr/local/lib/firefox/libxul.so +0x987aad0]
#16: std::__1::operator>><char, std::__1::char_traits<char>, std::__1::allocator<char> >(std::__1::basic_istream<char, std::__1::char_traits<char>>&, std::__1::basic_istream<char, std::__1::char_traits<char>>&, std::__1::basic_string<std::__1::basic_istream, c[/usr/local/lib/firefox/libxul.so +0x987b5f6]
#17: _start[/usr/local/bin/firefox +0x12586]
#18: _start[/usr/local/bin/firefox +0x1210d]
Segmentation fault(core dumped)

Here is core backtrace:

Core was generated by `firefox'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00000008013d324a in thr_kill () from /lib/libc.so.7
[Current thread is 1 (LWP 101054)]
(gdb) bt
#0  0x00000008013d324a in thr_kill () from /lib/libc.so.7
#1  0x00000008013d31c1 in raise () from /lib/libc.so.7
#2  0x000000080d65cd04 in nsProfileLock::FatalSignalHandler (signo=11, info=0x7fffffffbd30, context=0x7fffffffb9c0) at /usr/ports/www/firefox/work/firefox-72.0.1/toolkit/profile/nsProfileLock.cpp:169
#3  0x000000080120e56e in ?? () from /lib/libthr.so.3
#4  0x000000080120da6e in ?? () from /lib/libthr.so.3
#5  <signal handler called>
#6  mozilla::intl::LocaleService::GetDefaultLocale (this=0x813d72ae0, aRetVal=...) at /usr/ports/www/firefox/work/firefox-72.0.1/intl/locale/LocaleService.cpp:415
#7  0x00000008088a8161 in mozilla::intl::LocaleService::NegotiateAppLocales (this=0x813d72ae0, aRetVal=...) at /usr/ports/www/firefox/work/firefox-72.0.1/intl/locale/LocaleService.cpp:149
#8  0x00000008088aa99d in mozilla::intl::LocaleService::GetAppLocalesAsLangTags (this=0x813d72ae0, aRetVal=...) at /usr/ports/www/firefox/work/firefox-72.0.1/intl/locale/LocaleService.cpp:440
#9  0x00000008088aabdd in mozilla::intl::LocaleService::GetAppLocaleAsLangTag (this=0x0, aRetVal=...) at /usr/ports/www/firefox/work/firefox-72.0.1/intl/locale/LocaleService.cpp:466
#10 0x00000008088386f1 in nsChromeRegistryChrome::ChromePackageFromPackageEntry (aPackageName=..., aPackage=0x818080f60, aChromePackage=0x7fffffffcd68, aSelectedSkin=...) at /usr/ports/www/firefox/work/firefox-72.0.1/chrome/nsChromeRegistryChrome.cpp:304
#11 0x000000080883920a in nsChromeRegistryChrome::ManifestContent (this=<optimized out>, cx=..., lineno=<optimized out>, argv=<optimized out>, flags=0) at /usr/ports/www/firefox/work/firefox-72.0.1/chrome/nsChromeRegistryChrome.cpp:493
#12 0x00000008087d7f6c in ParseManifest (aType=NS_APP_LOCATION, aFile=..., aBuf=<optimized out>, aChromeOnly=false) at /usr/ports/www/firefox/work/firefox-72.0.1/xpcom/components/ManifestParser.cpp:653
#13 0x00000008087df156 in DoRegisterManifest (aType=<optimized out>, aFile=..., aChromeOnly=<optimized out>) at /usr/ports/www/firefox/work/firefox-72.0.1/xpcom/components/nsComponentManager.cpp:757
#14 nsComponentManagerImpl::RegisterManifest (this=<optimized out>, aType=NS_APP_LOCATION, aFile=..., aChromeOnly=false) at /usr/ports/www/firefox/work/firefox-72.0.1/xpcom/components/nsComponentManager.cpp:768
#15 0x00000008087df1e3 in nsComponentManagerImpl::ManifestManifest (this=<optimized out>, aCx=..., aLineNo=<optimized out>, aArgv=<optimized out>) at /usr/ports/www/firefox/work/firefox-72.0.1/xpcom/components/nsComponentManager.cpp:775
#16 0x00000008087d8011 in ParseManifest (aType=NS_APP_LOCATION, aFile=..., aBuf=<optimized out>, aChromeOnly=false) at /usr/ports/www/firefox/work/firefox-72.0.1/xpcom/components/ManifestParser.cpp:656
#17 0x00000008087df156 in DoRegisterManifest (aType=<optimized out>, aFile=..., aChromeOnly=<optimized out>) at /usr/ports/www/firefox/work/firefox-72.0.1/xpcom/components/nsComponentManager.cpp:757
#18 nsComponentManagerImpl::RegisterManifest (this=<optimized out>, aType=NS_APP_LOCATION, aFile=..., aChromeOnly=false) at /usr/ports/www/firefox/work/firefox-72.0.1/xpcom/components/nsComponentManager.cpp:768
#19 0x00000008087de59d in nsComponentManagerImpl::RereadChromeManifests (this=0x0, aChromeOnly=<optimized out>) at /usr/ports/www/firefox/work/firefox-72.0.1/xpcom/components/nsComponentManager.cpp:872
#20 0x00000008087dd9ce in nsComponentManagerImpl::Init (this=0x803d34b80) at /usr/ports/www/firefox/work/firefox-72.0.1/xpcom/components/nsComponentManager.cpp:530
#21 0x000000080884650b in NS_InitXPCOM (aResult=<optimized out>, aBinDirectory=0x803d333c0, aAppFileLocationProvider=<optimized out>, aInitJSContext=<optimized out>) at /usr/ports/www/firefox/work/firefox-72.0.1/xpcom/build/XPCOMInit.cpp:447
#22 0x000000080d66dae2 in ScopedXPCOMStartup::Initialize (this=0x8010c3838, aInitJSContext=false) at /usr/ports/www/firefox/work/firefox-72.0.1/toolkit/xre/nsAppRunner.cpp:1267
#23 0x000000080d67aad0 in XREMain::XRE_main (this=0x7fffffffe200, argc=<optimized out>, argv=<optimized out>, aConfig=...) at /usr/ports/www/firefox/work/firefox-72.0.1/toolkit/xre/nsAppRunner.cpp:4742
#24 0x000000080d67b5f6 in XRE_main (argc=0, argv=0x0, aConfig=...) at /usr/ports/www/firefox/work/firefox-72.0.1/toolkit/xre/nsAppRunner.cpp:4827
#25 0x0000000001033586 in do_main (argc=0, argv=0x7fffffffe838, envp=0x7fffffffe848) at /usr/ports/www/firefox/work/firefox-72.0.1/browser/app/nsBrowserApp.cpp:218
#26 main (argc=<optimized out>, argv=<optimized out>, envp=0x7fffffffe848) at /usr/ports/www/firefox/work/firefox-72.0.1/browser/app/nsBrowserApp.cpp:311
(gdb)

Previous versions of firefox was running without issues.
Comment 1 Jan Beich freebsd_committer 2020-01-13 03:16:27 UTC
Don't use DEBUG option. It's unstable on Tier3 platforms like FreeBSD.
See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=243301
Comment 2 Jan Beich freebsd_committer 2020-01-13 03:17:11 UTC
(In reply to Jan Beich from comment #1)
> See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=243301

Typo. I meant https://bugzilla.mozilla.org/show_bug.cgi?id=1497581
Comment 3 Jan Beich freebsd_committer 2020-01-13 03:22:29 UTC

*** This bug has been marked as a duplicate of bug 231491 ***
Comment 4 iron.udjin 2020-01-13 04:52:23 UTC
(In reply to Jan Beich from comment #3)
It's not a duplicate bug. Firefox crashed even withut DEBUG flag set:

$ firefox
[18583, Main Thread] WARNING: failed to freeze shm: Function not implemented: file /tmpfs/usr/ports/www/firefox/work/firefox-72.0.1/ipc/chromium/src/base/shared_memory_posix.cc, line 289
Segmentation fault(core dumped)

I have rebuild it with DEBUG flag to provide you [I hope] useful debug info. Because without debug backtrace is useless:

Core was generated by `firefox'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00000008013cd24a in thr_kill () from /lib/libc.so.7
[Current thread is 1 (LWP 100780)]
(gdb) bt
#0  0x00000008013cd24a in thr_kill () from /lib/libc.so.7
#1  0x00000008013cd1c1 in raise () from /lib/libc.so.7
#2  0x000000080905ee12 in ?? () from /usr/local/lib/firefox/libxul.so
#3  0x000000080120856e in ?? () from /lib/libthr.so.3
#4  0x0000000801207a6e in ?? () from /lib/libthr.so.3
#5  <signal handler called>
#6  0x0000000807ce971d in ?? () from /usr/local/lib/firefox/libxul.so
#7  0x0000000805bf6efa in ?? () from /usr/local/lib/firefox/libxul.so
#8  0x0000000805bf70de in ?? () from /usr/local/lib/firefox/libxul.so
#9  0x0000000805bf3f7f in ?? () from /usr/local/lib/firefox/libxul.so
#10 0x0000000807f6071d in ?? () from /usr/local/lib/firefox/libxul.so
#11 0x0000000807fa592b in ?? () from /usr/local/lib/firefox/libxul.so
#12 0x0000000807fc8bd6 in ?? () from /usr/local/lib/firefox/libxul.so
#13 0x0000000805b42440 in ?? () from /usr/local/lib/firefox/libxul.so
#14 0x0000000805b5037f in ?? () from /usr/local/lib/firefox/libxul.so
#15 0x0000000805b4cb09 in ?? () from /usr/local/lib/firefox/libxul.so
#16 0x0000000805b52a57 in ?? () from /usr/local/lib/firefox/libxul.so
#17 0x0000000805ad566e in ?? () from /usr/local/lib/firefox/libxul.so
#18 0x0000000808faddc5 in ?? () from /usr/local/lib/firefox/libxul.so
#19 0x0000000805b42404 in ?? () from /usr/local/lib/firefox/libxul.so
#20 0x0000000805b5037f in ?? () from /usr/local/lib/firefox/libxul.so
#21 0x0000000805b50741 in ?? () from /usr/local/lib/firefox/libxul.so
#22 0x0000000805b47bbf in ?? () from /usr/local/lib/firefox/libxul.so
#23 0x0000000805ad582e in ?? () from /usr/local/lib/firefox/libxul.so
#24 0x0000000809069d13 in ?? () from /usr/local/lib/firefox/libxul.so
#25 0x000000080907124d in ?? () from /usr/local/lib/firefox/libxul.so
#26 0x00000008090721b8 in ?? () from /usr/local/lib/firefox/libxul.so
#27 0x00000008090726ae in ?? () from /usr/local/lib/firefox/libxul.so
#28 0x00000000010308b6 in ?? ()
#29 0x000000000103010d in _start ()
(gdb)

Here is build options:
	ALSA           : on
	CANBERRA       : off
	DBUS           : on
	DEBUG          : off
	FFMPEG         : on
	GCONF          : off
	JACK           : off
	LIBPROXY       : off
	OPTIMIZED_CFLAGS: off
	PROFILE        : off
	PULSEAUDIO     : off
	SNDIO          : off
	TEST           : off
Comment 5 Jan Beich freebsd_committer 2020-01-13 05:52:35 UTC
(In reply to iron.udjin from comment #4)
> [18583, Main Thread] WARNING: failed to freeze shm: Function not implemented: file /tmpfs/usr/ports/www/firefox/work/firefox-72.0.1/ipc/chromium/src/base/shared_memory_posix.cc, line 289

www/firefox requires Capsicum enabled in kernel config since ports r522464.

*** This bug has been marked as a duplicate of bug 243252 ***