Bug 243315 - emulators/virtualbox-ose: 5.2.34 fails to buid on 11.3 with undefined reference to symbol `OPENSSL_init_ssl@@OPENSSL_1_1_0' (try adding -lssl)
Summary: emulators/virtualbox-ose: 5.2.34 fails to buid on 11.3 with undefined referen...
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: vbox
URL:
Keywords: needs-qa
: 243486 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-13 10:53 UTC by Philip Homburg
Modified: 2020-04-01 18:22 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (vbox)
koobs: merge-quarterly?


Attachments
poudriere log (569.90 KB, text/plain)
2020-01-13 10:53 UTC, Philip Homburg
no flags Details
[patch] remove hard-coded /usr/lib (974 bytes, patch)
2020-02-22 02:12 UTC, John Hein
jcfyecrayz: maintainer-approval? (vbox)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Homburg 2020-01-13 10:53:31 UTC
Created attachment 210692 [details]
poudriere log

Linker error. See attached (trimmed) poudriere log
Comment 1 John Hein 2020-02-22 00:19:59 UTC
I can confirm this.

For the offending link command, if you manually link with the first -L/usr/lib removed, it links successfully.

I have DEFAULT_VERSIONS=ssl=openssl in /etc/make.conf

I don't know yet how -L/usr/lib makes its way into the build.  It's not in CONFIGURE_{ARGS,ENV} nor MAKE_{ARGS,ENV}.
Comment 2 John Hein 2020-02-22 02:12:55 UTC
Created attachment 211823 [details]
[patch] remove hard-coded /usr/lib

I think the attached patch fixes the link error (if using ports openssl), but I did not test yet with DEFAULT_VERSIONS=ssl=base.
Comment 3 Bryan Drewery freebsd_committer 2020-03-26 22:29:33 UTC
*** Bug 243486 has been marked as a duplicate of this bug. ***
Comment 4 Bryan Drewery freebsd_committer 2020-03-26 22:30:53 UTC
(In reply to John Hein from comment #2)

Agreed with this patch. We just need to test it with base openssl as well.
Comment 5 commit-hook freebsd_committer 2020-03-31 17:41:48 UTC
A commit references this bug:

Author: bdrewery
Date: Tue Mar 31 17:41:05 UTC 2020
New revision: 529993
URL: https://svnweb.freebsd.org/changeset/ports/529993

Log:
  - Fix runtime for gcc rpath. [1]
    This is a regression of something that was working in the past. Please
    keep the _GCC_RUNTIME handling even if removing USE_GCC as it may
    come back again in the future and be forgotten.
  - Fix build on 11.3 with ports ssl. [2]

  PR:		245048 [1]
  PR:		243315 [2]
  Submitted by:	John Hein <jcfyecrayz at liamekaens.com> [2]

Changes:
  head/emulators/virtualbox-ose/Makefile
  head/emulators/virtualbox-ose/files/patch-src_VBox_RDP-client-1.8.4-Makefile.kmk
Comment 6 commit-hook freebsd_committer 2020-03-31 18:06:55 UTC
A commit references this bug:

Author: bdrewery
Date: Tue Mar 31 17:46:11 UTC 2020
New revision: 529997
URL: https://svnweb.freebsd.org/changeset/ports/529997

Log:
  MFH: r529993

  - Fix runtime for gcc rpath. [1]
    This is a regression of something that was working in the past. Please
    keep the _GCC_RUNTIME handling even if removing USE_GCC as it may
    come back again in the future and be forgotten.
  - Fix build on 11.3 with ports ssl. [2]

  PR:		245048 [1]
  PR:		243315 [2]
  Submitted by:	John Hein <jcfyecrayz at liamekaens.com> [2]

  Approved by:	portmgr (implicit)

Changes:
_U  branches/2020Q1/
  branches/2020Q1/emulators/virtualbox-ose/Makefile
  branches/2020Q1/emulators/virtualbox-ose/files/patch-src_VBox_RDP-client-1.8.4-Makefile.kmk
Comment 7 John Hein 2020-04-01 18:22:36 UTC
(In reply to Bryan Drewery from comment #4)
I did test this with ssl=base after your comment.  I know you've committed it, so you may have also tested it.  Either way, I'm mentioning it for the record...

Thanks for the commit.