Bug 243320 - www/firefox: 72.0.1_1,1 crash on start
Summary: www/firefox: 72.0.1_1,1 crash on start
Status: Closed DUPLICATE of bug 243252
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gecko (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-13 14:41 UTC by rozhuk.im
Modified: 2020-01-15 13:34 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (gecko)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rozhuk.im 2020-01-13 14:41:26 UTC
[14897, Main Thread] WARNING: failed to freeze shm: Function not implemented: file /tmp/ports/usr/ports/www/firefox/work/firefox-72.0.1/ipc/chromium/src/base/shared_memory_posix.cc, line 289
Segmentation fault (core dumped)

=============================================================================
#elif defined(__FreeBSD__)
  cap_rights_t rights;
  cap_rights_init(&rights, CAP_MMAP_R);
  if (cap_rights_limit(mapped_file_, &rights) != 0) {
    CHROMIUM_LOG(WARNING) << "failed to freeze shm: " << strerror(errno);
    //return false; // - My temp FIX - works.
  }
=============================================================================

Better to check ENOSYS != errno:
if (cap_rights_limit(mapped_file_, &rights) != 0 && ENOSYS != errno) {
and only in this case fail.
Comment 2 Jan Beich freebsd_committer 2020-01-15 13:32:05 UTC
(In reply to rozhuk.im from comment #0)
>    //return false; // - My temp FIX - works.

Failing to freeze means an untrusted child process has write access. The feature is currently used by parent process to pass read-only snapshot of preferences to content processes.
Comment 3 Jan Beich freebsd_committer 2020-01-15 13:34:40 UTC
Let's discuss possible solutions in one place with feedback from the author.

*** This bug has been marked as a duplicate of bug 243252 ***