Bug 243362 - www/falkon crash at or soon after launch time
Summary: www/falkon crash at or soon after launch time
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-15 02:05 UTC by Graham Perrin
Modified: 2020-01-19 11:59 UTC (History)
2 users (show)

See Also:
tcberner: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin 2020-01-15 02:05:02 UTC
grahamperrin@momh167-gjp4-8570p:~ % date ; uname -vKU
Wed 15 Jan 2020 02:01:39 GMT
FreeBSD 13.0-CURRENT #50 r356618: Sat Jan 11 04:50:38 GMT 2020     root@momh167-gjp4-8570p:/usr/obj/usr/src/amd64.amd64/sys/GENERIC-NODEBUG  1300076 1300076
grahamperrin@momh167-gjp4-8570p:~ % falkon
QWebEngineUrlScheme::registerScheme: Too late to register scheme "falkon"
QWebEngineUrlScheme::registerScheme: Too late to register scheme "extension"
Please register the custom scheme 'falkon' via QWebEngineUrlScheme::registerScheme() before installing the custom scheme handler.
Please register the custom scheme 'extension' via QWebEngineUrlScheme::registerScheme() before installing the custom scheme handler.
Use of deprecated not thread-safe setter, use setUrlRequestInterceptor instead.
Falkon: 1 extensions loaded
Bus error (core dumped)
grahamperrin@momh167-gjp4-8570p:~ % pkg query '%o %v %R' falkon
www/falkon 3.1.0 FreeBSD
grahamperrin@momh167-gjp4-8570p:~ %
Comment 1 Graham Perrin 2020-01-15 02:33:36 UTC
Reading this alongside e.g. bug 241027

I'm now building with poudriere – 

root@momh167-gjp4-8570p:~ # date ; uname -vKU
Wed Jan 15 02:15:21 GMT 2020
FreeBSD 13.0-CURRENT #50 r356618: Sat Jan 11 04:50:38 GMT 2020     root@momh167-gjp4-8570p:/usr/obj/usr/src/amd64.amd64/sys/GENERIC-NODEBUG  1300076 1300076
root@momh167-gjp4-8570p:~ # poudriere bulk -C -j head www/falkon
…

– but I guess, it'll be a few hours before I have a result.
Comment 2 Tobias C. Berner freebsd_committer 2020-01-18 20:57:46 UTC
Cannot reproduce this here. How long does it take to crash for you?
Comment 3 Graham Perrin 2020-01-19 11:59:06 UTC
(In reply to Tobias C. Berner from comment #2)

> Cannot reproduce this here. …

OK! 

Crashes seemed to occur when starting a new session, or restoring a session. 

I found a number of crashing bugs in the KDE area, most noticeably: 

408701 – Crash at restore page > Start New Session
https://bugs.kde.org/show_bug.cgi?id=408701

I took a hint from a more recent bug: 

415680 – QtWebEngine crashes with QtCurve on exit
https://bugs.kde.org/show_bug.cgi?id=415680

In system settings, I changed: 

* application style from Breeze to Oxygen
* window decorations from Breezemite dark to Oxygen

– after which, Falkon ceased crashing. Touch wood. 

Reverting application style and window decorations did not make the bug reproducible. 

I'll add a screen recording to KDE bug 408701, with reference to some of the other crashing bugs. 

Closing (unable to reproduce) but feel free to reopen if necessary.