Bug 243378 - sysutils/polkit: Update to 0.116
Summary: sysutils/polkit: Update to 0.116
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-desktop (Team)
URL:
Keywords:
Depends on: 242085
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-15 20:00 UTC by Olivier Duchateau
Modified: 2020-02-11 18:38 UTC (History)
1 user (show)

See Also:
tcberner: maintainer-feedback+


Attachments
Patch to update sysutils/polkit (3.36 KB, patch)
2020-01-15 20:00 UTC, Olivier Duchateau
no flags Details | Diff
Patch to update sysutils/polkit (3.35 KB, patch)
2020-01-26 12:29 UTC, Olivier Duchateau
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Duchateau 2020-01-15 20:00:10 UTC
Created attachment 210769 [details]
Patch to update sysutils/polkit

- Update to 0.116
- Adjust dependencies (remove dbus, polkit* uses gdbus from Gio)
- Add upstream patch (fixes memory leaks)
Comment 1 Tobias C. Berner freebsd_committer 2020-01-16 05:24:39 UTC
Moin moin

Awesome thanks for this -- unfortunately spidermonky60 is broken atm on i386, which blocks this.



mfg Tobias
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-01-16 09:15:11 UTC
(In reply to Tobias C. Berner from comment #1)

I did a quick bugzilla search but couldnt find a bug for the spidermonkey/i386 issue. Could you create a blocking bug with relevant info (maybe the latest build log before BROKEN or something)
Comment 3 Tobias C. Berner freebsd_committer 2020-01-16 17:24:59 UTC
(In reply to Kubilay Kocak from comment #2)
I mean these fallout messages I've been getting for months :) 
http://beefy5.nyi.freebsd.org/data/120i386-default/522465/logs/spidermonkey60-60.9.0.log
Comment 4 Tobias C. Berner freebsd_committer 2020-01-18 21:00:00 UTC
(In reply to Tobias C. Berner from comment #3)
spidermonkey60 should now build on i386 after r523492 .
Comment 5 Tobias C. Berner freebsd_committer 2020-01-19 07:32:41 UTC
Moin moin 

why did you remove:

RUN_DEPENDS=	dbus-launch:devel/dbus 


mfg Tobias
Comment 6 Olivier Duchateau 2020-01-19 14:41:14 UTC
(In reply to Tobias C. Berner from comment #5)

I confused with dbus-glib, Run_DEPENDS is required, you are right.
Comment 7 Tobias C. Berner freebsd_committer 2020-01-25 21:18:41 UTC
Could you upload the corrected patch (with respect to the dbus dependency)?
Then I think it's time to ship it.
Comment 8 Olivier Duchateau 2020-01-26 12:29:29 UTC
Created attachment 211061 [details]
Patch to update sysutils/polkit

Update patch (fix dependency).
Comment 9 commit-hook freebsd_committer 2020-02-11 18:38:29 UTC
A commit references this bug:

Author: tcberner
Date: Tue Feb 11 18:37:37 UTC 2020
New revision: 525883
URL: https://svnweb.freebsd.org/changeset/ports/525883

Log:
  sysutils/polkit: Update to 0.116

  PR:		243378
  Submitted by:	Olivier Duchateau <duchateau.olivier@gmail.com>

Changes:
  head/sysutils/polkit/Makefile
  head/sysutils/polkit/distinfo
  head/sysutils/polkit/files/patch-src_polkitbackend_polkitbackendjsauthority.cpp
  head/sysutils/polkit/pkg-plist
Comment 10 Tobias C. Berner freebsd_committer 2020-02-11 18:38:43 UTC
Thanks again for working on this patch -- finally committed.