Bug 243409 - graphics/ephoto: configure build failure
Summary: graphics/ephoto: configure build failure
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Loïc Bartoletti
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-17 11:17 UTC by Nuno Teixeira
Modified: 2020-05-20 11:00 UTC (History)
0 users

See Also:
lbartoletti: maintainer-feedback+


Attachments
my poudriere log (94.39 KB, text/plain)
2020-01-18 10:52 UTC, Loïc Bartoletti
no flags Details
poudriere error log (39.71 KB, text/plain)
2020-01-22 19:55 UTC, Nuno Teixeira
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nuno Teixeira 2020-01-17 11:17:35 UTC
Hello,

I'm compiling ephoto in poudriere, FreeBSD 12.1:

#########
...
checking where the gettext function comes from... external libintl
checking how to link with libintl... /usr/local/lib/libintl.so -Wl,-rpath -Wl,/usr/local/lib
checking pkg-config is at least version 0.9.0... yes
checking for EFL... no
configure: error: Package requirements (eina >= 1.18.0 evas >= 1.18.0 ecore >= 1.18.0 ecore-file >=
1.18.0 ecore-ipc >= 1.18.0 edje >= 1.18.0 eo >= 1.18.0 eio >= 1.18.0
elementary >= 1.18.0 efreet-mime >= 1.18.0) were not met:

Package 'ecore-audio', required by 'edje', not found
Package 'ecore-audio', required by 'edje', not found
Package 'ecore-audio', required by 'edje', not found
Package 'ecore-audio', required by 'edje', not found
Package 'ecore-audio', required by 'edje', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables EFL_CFLAGS
and EFL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
===>  Script "configure" failed unexpectedly.
Please report the problem to lbartoletti@FreeBSD.org [maintainer] and attach
the "/wrkdirs/usr/ports/graphics/ephoto/work/ephoto-1.5/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/graphics/ephoto
=>> Cleaning up wrkdir
===>  Cleaning for ephoto-1.5_4
build of graphics/ephoto | ephoto-1.5_4 ended at Fri Jan 17 03:12:00 WET 2020
build time: 00:04:37
!!! build failure encountered !!!
#########

It seems that configure doesn't find efl libraries?

Thanks,

Nuno Teixeira
Comment 1 Loïc Bartoletti freebsd_committer 2020-01-18 10:52:15 UTC
Created attachment 210837 [details]
my poudriere log
Comment 2 Loïc Bartoletti freebsd_committer 2020-01-18 10:53:43 UTC
Hmm I can't reproduce the problem. Can you try to clean EFL pkg and retest please?
Comment 3 Nuno Teixeira 2020-01-22 19:55:37 UTC
Created attachment 210972 [details]
poudriere error log

Hello,

I have same error after a poudriere pkgclean -A.

Thanks,

Nuno