Bug 243457 - [NEW PORT] devel/cargo-generate: Quickly generate Rust project templates from existing git repositories
Summary: [NEW PORT] devel/cargo-generate: Quickly generate Rust project templates from...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL: https://github.com/ashleygwilliams/ca...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-19 21:09 UTC by Lewis Cook
Modified: 2020-09-04 02:01 UTC (History)
0 users

See Also:


Attachments
cargo-generate-0.5.0.diff (40.44 KB, patch)
2020-01-19 21:09 UTC, Lewis Cook
no flags Details | Diff
cargo-generate-0.5.0.log (232.67 KB, text/plain)
2020-01-19 21:10 UTC, Lewis Cook
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lewis Cook freebsd_triage 2020-01-19 21:09:33 UTC
Created attachment 210876 [details]
cargo-generate-0.5.0.diff

Developer tool to help you get up and running
quickly with a new Rust project by leveraging
a pre-existing git repository as a template.

WWW: https://github.com/ashleygwilliams/cargo-generate

QA: 
  * Portlint: Looks fine;
  * Poudriere: Package built, application works as intended.
Comment 1 Lewis Cook freebsd_triage 2020-01-19 21:10:03 UTC
Created attachment 210877 [details]
cargo-generate-0.5.0.log

* Poudriere build log.
Comment 2 commit-hook freebsd_committer 2020-09-04 02:00:51 UTC
A commit references this bug:

Author: swills
Date: Fri Sep  4 02:00:10 UTC 2020
New revision: 547497
URL: https://svnweb.freebsd.org/changeset/ports/547497

Log:
  devel/cargo-generate: create port

  Developer tool to help you get up and running quickly with a new Rust project
  by leveraging a pre-existing git repository as a template.

  WWW: https://github.com/ashleygwilliams/cargo-generate

  PR:		243457
  Submitted by:	Lewis Cook <vulcan@wired.sh>

Changes:
  head/devel/Makefile
  head/devel/cargo-generate/
  head/devel/cargo-generate/Makefile
  head/devel/cargo-generate/distinfo
  head/devel/cargo-generate/pkg-descr
Comment 3 Steve Wills freebsd_committer 2020-09-04 02:01:36 UTC
Committed, thanks!