Bug 243477 - mail/mu4e-maildirs: This port is not compatible with latest version of dash.el
Summary: mail/mu4e-maildirs: This port is not compatible with latest version of dash.el
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Hiroki Sato
URL:
Keywords:
Depends on:
Blocks: 243474
  Show dependency treegraph
 
Reported: 2020-01-20 19:35 UTC by Yasuhiro KIMURA
Modified: 2020-02-21 00:50 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (hrs)


Attachments
Fix byte-compilation with the updated dash.el (691 bytes, patch)
2020-01-21 15:29 UTC, Hiroki Sato
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro KIMURA 2020-01-20 19:35:19 UTC
I submitted bug #243474 that updates devel/dash.el to 2.17.0. But after that I found this port is not compatible with this version of dash.el. That is, build of this port fails as following.

https://www.utahime.org/FreeBSD/poudriere/data/logs/bulk/curamd64-git/2020-01-21_04h07m09s/logs/mu4e-maildirs-emacs26-0.8.20180606_1.log

I checked upstream but there is no solution of this problem at this time.
Comment 1 Hiroki Sato freebsd_committer 2020-01-21 15:29:38 UTC
Created attachment 210916 [details]
Fix byte-compilation with the updated dash.el

This patch should fix the compilation issue.  Please test this with your updated dash.el and let me know if it works.
Comment 2 Yasuhiro KIMURA 2020-01-22 01:42:01 UTC
(In reply to Hiroki Sato from comment #1)

Thanks. I tried your patch and confirmed build succeeds with dash.el 2.17.0. I also confirmed it works fine with current devel/dash.el. So please commit it.
Comment 3 Yasuhiro KIMURA 2020-02-21 00:50:18 UTC
The problem is fixed with ports r526482.