Bug 243539 - math/maxima: SBCL version mismatch
Summary: math/maxima: SBCL version mismatch
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias C. Berner
URL:
Keywords:
Depends on: 243543
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-23 10:50 UTC by yzrh
Modified: 2020-01-31 22:45 UTC (History)
3 users (show)

See Also:
salvadore: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yzrh 2020-01-23 10:50:18 UTC
Starting maxima results in:

fatal error encountered in SBCL pid 96509(tid 0x800730000):
core was built for runtime "120amd64-default-job-20-root-2019-10-27-05-56-32" but this is "120amd64-default-job-23-root-2019-12-31-02-24-40"

version:

sbcl-2.0.0,1
maxima-5.43.0_3
Comment 1 Lorenzo Salvadore freebsd_committer 2020-01-23 11:03:32 UTC
This happened because sbcl was updated in the ports tree without bumping PORTREVISION for maxima.

I will not submit a patch to fix this because I am about to update maxima to 5.43.1, which will solve your issue too. I will submit the update today or tomorrow and link the PR to this PR for your convenience.

If, for some reason, you can not wait for the coming update, just rebuild maxima from ports on your system: it should be enough.
Comment 2 Lorenzo Salvadore freebsd_committer 2020-01-23 11:13:32 UTC
I CC sbcl maintainer so he can check if he forgot bumping PORTREVISION for other ports.
Comment 3 yzrh 2020-01-23 11:17:33 UTC
Thanks for the quick response.

Since building from ports will take a long time on my hardware (core duo, core 2 duo), I should just wait for the update.
Comment 4 Lorenzo Salvadore freebsd_committer 2020-01-23 14:40:37 UTC
Patch fo updating to 5.43.1, that should solve this issue as well, can be found at bug #243543.
Comment 5 Lorenzo Salvadore freebsd_committer 2020-01-25 10:31:04 UTC
The update has been committed. Please confirm that the issue is solved when you can install it.
Comment 6 yzrh 2020-01-31 11:08:41 UTC
I can confirm that maxima starts without problem after updating to maxima-5.43.1_1.
Comment 7 Walter Schwarzenfeld freebsd_triage 2020-01-31 15:41:27 UTC
Fixed in Bug #243543.
Comment 8 Kubilay Kocak freebsd_committer freebsd_triage 2020-01-31 22:45:35 UTC
^Triage: Assign to committer that resolved