Bug 243542 - devel/racerd: fails to build with rust-nightly
Summary: devel/racerd: fails to build with rust-nightly
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Richard Gallamore
URL:
Keywords: needs-patch
Depends on:
Blocks:
 
Reported: 2020-01-23 13:54 UTC by Tobias Kortkamp
Modified: 2020-02-14 04:50 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (ultima)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Kortkamp freebsd_committer 2020-01-23 13:54:55 UTC
racerd is severely out of date.  Please update it.  It now fails to build with
rust-nightly and I expect it will soon fail to build with stable Rust too (not
the first time, see ports r520311).

error[E0423]: expected function, tuple struct or tuple variant, found struct `ast::Name`
   --> /wrkdirs/usr/ports/devel/racerd/work/racerd-0.1.1-56-g29cd4c6/cargo-crates/syntex_syntax
-0.54.0/src/symbol.rs:146:27
    |
146 |                       name: ast::Name($index),
    |                             ^^^^^^^^^
...
165 | / declare_keywords! {
166 | |     // Invalid identifier
167 | |     (0,  Invalid,        "")
168 | |
...   |
231 | |     (56, CrateRoot, "{{root}}")
232 | | }
    | |_- in this macro invocation

error[E0423]: expected function, tuple struct or tuple variant, found struct `ast::Name`
   --> /wrkdirs/usr/ports/devel/racerd/work/racerd-0.1.1-56-g29cd4c6/cargo-crates/syntex_syntax
-0.52.0/src/symbol.rs:146:27
    |
146 |                       name: ast::Name($index),
    |                             ^^^^^^^^^
...
165 | / declare_keywords! {
166 | |     // Invalid identifier
167 | |     (0,  Invalid,        "")
168 | |
...   |
228 | |     (55, Union,          "union")
229 | | }
    | |_- in this macro invocation

Maybe we can just drop the port?  Do we still need it?  Nowadays lang/rust comes with an LSP server,
rls, which should be enough of a replacement.  Since rls comes with Rust, it will always be up to
date and support the current Rust version.  Most popular editors can make use of LSP servers.
Comment 1 Tobias Kortkamp freebsd_committer 2020-01-28 13:10:06 UTC
Marked as broken for lang/rust 1.41.0 (see https://reviews.freebsd.org/D23385).
Comment 2 commit-hook freebsd_committer 2020-02-11 08:46:42 UTC
A commit references this bug:

Author: tobik
Date: Tue Feb 11 08:46:34 UTC 2020
New revision: 525795
URL: https://svnweb.freebsd.org/changeset/ports/525795

Log:
  Deprecate devel/racerd

  racerd has not been updated for more than 2 years and is causing
  extra work during lang/rust updates.  Let it expire in 2 weeks.
  lang/rust comes with its own language server, RLS, that can be used
  instead.

  PR:		243542
  Approved by:	ultima (maintainer timeout, 18 days)

Changes:
  head/devel/racerd/Makefile
Comment 3 Richard Gallamore freebsd_committer 2020-02-11 20:24:46 UTC
(In reply to Tobias Kortkamp from comment #0)
Hey Tobias,

 Somehow this bug slipped by and I didn't see it. I'm actually planning on deleting this port as well as a couple of others, I just haven't gotten around to it. If you want to go ahead and remove it that is fine.
Comment 4 Richard Gallamore freebsd_committer 2020-02-14 04:50:09 UTC
Deleted port in r526085.