Bug 243547 - sysutils/metalog: guard non-standard fflush_unlocked definition behind #ifndef
Summary: sysutils/metalog: guard non-standard fflush_unlocked definition behind #ifndef
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-23 15:22 UTC by Kyle Evans
Modified: 2020-01-23 18:55 UTC (History)
0 users

See Also:


Attachments
svn(1) diff against the ports tree (501 bytes, patch)
2020-01-23 15:22 UTC, Kyle Evans
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle Evans freebsd_committer 2020-01-23 15:22:06 UTC
Created attachment 210990 [details]
svn(1) diff against the ports tree

A future change to FreeBSD's libc will provide this, so no need to use the locked variant. Preemptively fix the build so it works for both old/new by detecting whether fflush_unlocked is already defined or not.

The patch will still be needed for DragonflyBSD compatibility, but the __FreeBSD__ part of this can be removed later once all supported versions provide fflush_unlocked.

No PORTREVISION bump because this change is a nop until the libc implementation is committed.
Comment 1 Kyle Evans freebsd_committer 2020-01-23 18:55:59 UTC
The status quo is fine for now- will reopen later after new versions make their way into stable branches, since the current definition will just leave fflush_unlocked unused.