Bug 243550 - databases/grass7: fail to update/install: r.watershed/seg failed: No such file or directory
Summary: databases/grass7: fail to update/install: r.watershed/seg failed: No such fil...
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Loïc Bartoletti
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-23 20:23 UTC by Martin Birgmeier
Modified: 2020-06-08 17:13 UTC (History)
0 users

See Also:
lbartoletti: maintainer-feedback+


Attachments
make log (599.10 KB, text/plain)
2020-01-23 20:23 UTC, Martin Birgmeier
no flags Details
ports installed together with grass7 on the build VM (29.02 KB, text/plain)
2020-04-05 08:09 UTC, Martin Birgmeier
no flags Details
grass without fortran (6.24 KB, patch)
2020-04-19 21:30 UTC, Loïc Bartoletti
no flags Details | Diff
listing of installed ports + 3 logs of portmaster runs (865.60 KB, application/x-compressed-tar)
2020-04-21 19:21 UTC, Martin Birgmeier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2020-01-23 20:23:32 UTC
Created attachment 210994 [details]
make log

I am regularly bitten by the issue described in bug #235174. After removing .build_done.grass._usr_local and .stage_done.grass._usr_local and then restarting the make in ports/databases/grass7, the attached log is produced.

There it seems that core dumps prevent the creation of some files?

After running this several times the port build seems to complete and the install is successful.

-- Martin
Comment 1 Loïc Bartoletti freebsd_committer 2020-02-11 07:16:32 UTC
Please, can you attach the log when there is an error?
watershed/seg module seems flasky
Comment 2 Martin Birgmeier 2020-02-11 19:12:02 UTC
Hi  Loïc,

I did attach it already when submitting the issue; the error is clearly visible in this log (there are core dumps). Do you need something different?

-- Martin
Comment 3 Loïc Bartoletti freebsd_committer 2020-04-02 13:35:17 UTC
I update databases/grass7 to 7.8.2. Can you try it please? Normally, I fixed this long standing issue (I hope! ;) )
Comment 4 Martin Birgmeier 2020-04-03 14:41:02 UTC
Hello Loïc,

Unfortunately there still seems to be the same behavior:

===>>> All >> qgis-3.10.1_3 >> databases/grass7 (16/17)                                                                             
                                                                                                                                    
===>  Installing for grass7-7.8.2                                                                                                   
===>  Checking if grass7 is already installed                                                                                       
===>   Registering installation for grass7-7.8.2 as automatic                                                                       
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/bcyr.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/bgyr.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/byg.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/byr.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/celsius.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/corine.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/greens.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/grey.eq.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/grey.log.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/grey.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/grey255.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/oranges.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/precipitation_monthly.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/random.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/sepia.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/soilmoisture.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/srtm.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/terrain.png:No such file or directory
pkg-static: Unable to access file /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/stage/usr/local/grass78/docs/html/colortables/viridis.png:No such file or directory
*** Error code 74                                                 

Stop.                                                             
make[1]: stopped in /a/SRC/FreeBSD-ports/head/databases/grass7                                                                      
*** Error code 1                                                  

Stop.                                                             
make: stopped in /a/SRC/FreeBSD-ports/head/databases/grass7                                                                         

===>>> Installation of grass7-7.8.2 (databases/grass7) failed                                                                       
===>>> Aborting update                                            

===>>> Update for databases/grass7 failed                                                                                           
===>>> Aborting update                                            

===>>> Update for graphics/qgis failed                            
===>>> Aborting update                                            

===>>> There are messages from installed ports to display,                                                                          
       but first take a moment to review the error messages                                                                         
       above.  Then press Enter when ready to proceed.                                                                              

[1]# find /usr/tmp -name '*.core'
/usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/grass-7.8.2/gui/wxpython/i.atcorr.core
/usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/grass-7.8.2/gui/wxpython/r.terraflow.core
/usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/grass-7.8.2/gui/wxpython/r.viewshed.core
/usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/grass-7.8.2/imagery/i.atcorr/i.atcorr.core
/usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/grass-7.8.2/raster/r.terraflow/r.terraflow.core
/usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/grass-7.8.2/raster/r.viewshed/r.viewshed.core
[0]# 

-- Martin
Comment 5 Loïc Bartoletti freebsd_committer 2020-04-03 17:39:56 UTC
Hi Martin,

argh... what are your options (make -C /usr/ports/databases/grass7 showconfig) ?

Mine (only ODBC is different from default):
```
===> The following configuration options are available for grass7-7.8.2:
     LAS=on: Enable LiDAR modules
     NETCDF=on: NetCDF data format support
     NLS=on: Native Language Support
     PDAL=on: Enable points cloud data modules
     ZSTD=on: Zstandard compression support
====> Database support: you have to choose at least one of them
     MYSQL=off: MySQL database support
     ODBC=on: ODBC database backend
     PGSQL=on: PostgreSQL database support
     SQLITE=on: SQLite database support
===> Use 'make config' to modify these settings
``` 

And from the build part:

```
Copying config.status to config.status.amd64-portbld-freebsd12.1

GRASS is now configured for:  amd64-portbld-freebsd12.1

  Source directory:           /usr/ports/databases/grass7/work/grass-7.8.2
  Build directory:            /usr/ports/databases/grass7/work/grass-7.8.2
  Installation directory:     ${prefix}/grass78
  Startup script in directory:${exec_prefix}/bin
  C compiler:                 gcc9 -O2 -pipe  -DLIBICONV_PLUG -fstack-protector-strong -Wl,-rpath=/usr/local/lib/gcc9 -fno-strict-aliasing  
  C++ compiler:               g++9 -O2 -pipe  -DLIBICONV_PLUG -fstack-protector-strong -Wl,-rpath=/usr/local/lib/gcc9  -DLIBICONV_PLUG -Wl,-rpath=/usr/local/lib/gcc9 
  Building shared libraries:  yes
  OpenGL platform:            X11

  MacOSX application:         no
  MacOSX architectures:       
  MacOSX SDK:                 

  BLAS support:               yes
  BZIP2 support:              no
  C++ support:                yes
  Cairo support:              yes
  DWG support:                no
  FFTW support:               yes
  FreeType support:           yes
  GDAL support:               yes
  GEOS support:               yes
  LAPACK support:             yes
  Large File support (LFS):   yes
  libLAS support:             yes
  MySQL support:              no
  NetCDF support:             yes
  NLS support:                yes
  ODBC support:               yes
  OGR support:                yes
  OpenCL support:             no
  OpenGL support:             yes
  OpenMP support:             yes
  PDAL support:               yes
  PNG support:                yes
  POSIX thread support:       yes
  PostgreSQL support:         yes
  Readline support:           yes
  Regex support:              yes
  SQLite support:             yes
  TIFF support:               yes
  X11 support:                yes
  Zstandard support:          yes

  using new PROJ 5+ API

===>  Building for grass7-7.8.2
```
Comment 6 Martin Birgmeier 2020-04-03 19:17:31 UTC
I am sorry... I usually get around this by removing the .build_done and .stage_done files in the port build directory and restarting. The files built this way are certainly wrong, but for my purposes of getting qgis to work it seems to be good enough.

Also, on my build system the various ports are pulling in gcc9, llvm80, and llvm90. I suspect that there might be clashes between what they produce?

Anyway, here the answers to your questions:

[0]# cd /usr/ports/databases/grass7 
[0]# make showconfig
===> The following configuration options are available for grass7-7.8.2:
     LAS=on: Enable LiDAR modules
     NETCDF=on: NetCDF data format support
     NLS=on: Native Language Support
     PDAL=on: Enable points cloud data modules
     ZSTD=on: Zstandard compression support
====> Database support: you have to choose at least one of them
     MYSQL=on: MySQL database support
     ODBC=on: ODBC database backend
     PGSQL=on: PostgreSQL database support
     SQLITE=on: SQLite database support
===> Use 'make config' to modify these settings
[0]# 

So only MYSQL is different.

Copying config.status to config.status.amd64-portbld-freebsd12.1

GRASS is now configured for:  amd64-portbld-freebsd12.1

  Source directory:           /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/grass-7.8.2
  Build directory:            /usr/tmp/a/SRC/FreeBSD-ports/head/databases/grass7/work/grass-7.8.2
  Installation directory:     ${prefix}/grass78
  Startup script in directory:${exec_prefix}/bin
  C compiler:                 gcc9 -O2 -pipe  -DLIBICONV_PLUG -fstack-protector-strong -Wl,-rpath=/usr/local/lib/gcc9 -fno-strict-aliasing  
  C++ compiler:               g++9 -O2 -pipe  -DLIBICONV_PLUG -fstack-protector-strong -Wl,-rpath=/usr/local/lib/gcc9  -DLIBICONV_PLUG -Wl,-rpath=/usr/local/lib/gcc9 
  Building shared libraries:  yes
  OpenGL platform:            X11

  MacOSX application:         no
  MacOSX architectures:       
  MacOSX SDK:                 

  BLAS support:               yes
  BZIP2 support:              no
  C++ support:                yes
  Cairo support:              yes
  DWG support:                no
  FFTW support:               yes
  FreeType support:           yes
  GDAL support:               yes
  GEOS support:               yes
  LAPACK support:             yes
  Large File support (LFS):   yes
  libLAS support:             yes
  MySQL support:              yes
  NetCDF support:             yes
  NLS support:                yes
  ODBC support:               yes
  OGR support:                yes
  OpenCL support:             no
  OpenGL support:             yes
  OpenMP support:             yes
  PDAL support:               yes
  PNG support:                yes
  POSIX thread support:       yes
  PostgreSQL support:         yes
  Readline support:           yes
  Regex support:              yes
  SQLite support:             yes
  TIFF support:               yes
  X11 support:                yes
  Zstandard support:          yes

  using new PROJ 5+ API

===>  Building for grass7-7.8.2
Comment 7 Loïc Bartoletti freebsd_committer 2020-04-05 05:51:00 UTC
I tried with MySQL enabled and cannot reproduce the issue. So, which ports are installed on your machine? What's the options of graphics/gdal?

Thanks.
Comment 8 Martin Birgmeier 2020-04-05 08:09:02 UTC
Created attachment 213085 [details]
ports installed together with grass7 on the build VM

Hello Loïc,

Thanks a lot for putting so much work into this.

[0]# cat /var/db/ports/graphics_gdal/options 
# This file is auto-generated by 'make config'.
# Options for gdal-2.4.0
_OPTIONS_READ=gdal-2.4.0
_FILE_COMPLETE_OPTIONS_LIST=ARMADILLO CFITSIO CURL ECW EXPAT FREEXL GEOS GTA HDF5 JASPER KML LIBXML2 MYSQL NETCDF ODBC OPENJPEG PCRE PGSQL SFCGAL SPATIALITE SQLITE WEBP XERCES ZSTD PODOFO POPPLER
OPTIONS_FILE_UNSET+=ARMADILLO
OPTIONS_FILE_SET+=CFITSIO
OPTIONS_FILE_SET+=CURL
OPTIONS_FILE_UNSET+=ECW
OPTIONS_FILE_UNSET+=EXPAT
OPTIONS_FILE_UNSET+=FREEXL
OPTIONS_FILE_SET+=GEOS
OPTIONS_FILE_UNSET+=GTA
OPTIONS_FILE_SET+=HDF5
OPTIONS_FILE_SET+=JASPER
OPTIONS_FILE_SET+=KML
OPTIONS_FILE_SET+=LIBXML2
OPTIONS_FILE_SET+=MYSQL
OPTIONS_FILE_UNSET+=NETCDF
OPTIONS_FILE_SET+=ODBC
OPTIONS_FILE_SET+=OPENJPEG
OPTIONS_FILE_UNSET+=PCRE
OPTIONS_FILE_SET+=PGSQL
OPTIONS_FILE_UNSET+=SFCGAL
OPTIONS_FILE_UNSET+=SPATIALITE
OPTIONS_FILE_UNSET+=SQLITE
OPTIONS_FILE_UNSET+=WEBP
OPTIONS_FILE_UNSET+=XERCES
OPTIONS_FILE_UNSET+=ZSTD
OPTIONS_FILE_UNSET+=PODOFO
OPTIONS_FILE_UNSET+=POPPLER
[0]# 

I have added the ports installed on that machine as an attachment.

-- Martin
Comment 9 Loïc Bartoletti freebsd_committer 2020-04-19 21:30:30 UTC
Created attachment 213577 [details]
grass without fortran

I cannot reprodue the issue (but not yet tested in a vm with your installed ports)

Meanwhile, can you try this patch? Thanks
Comment 10 Loïc Bartoletti freebsd_committer 2020-04-21 15:43:18 UTC
(In reply to Loïc Bartoletti from comment #9)
I installed your packages in a jail and cannot reproduce the issue.
maybe can you try a make clean deinstall install?
Comment 11 Martin Birgmeier 2020-04-21 17:03:15 UTC
Hi Loïc,

Thanks a lot for your efforts!

I guess there must be other options in other packages which lead to this behavior - I do not compile all packages with default options.

I'll try your patch...

In the meantime, with grass7-7.8.2 installed, how does this output compare to what you get:

[0]# ldd /usr/local/grass78/lib/libgrass_vector.7.8.so
/usr/local/grass78/lib/libgrass_vector.7.8.so:
        libgrass_dbmiclient.7.8.so => /usr/local/grass78/lib/libgrass_dbmiclient.7.8.so (0x801079000)
        libgrass_dbmibase.7.8.so => /usr/local/grass78/lib/libgrass_dbmibase.7.8.so (0x801284000)
        libgrass_dgl.7.8.so => /usr/local/grass78/lib/libgrass_dgl.7.8.so (0x801495000)
        libgrass_dig2.7.8.so => /usr/local/grass78/lib/libgrass_dig2.7.8.so (0x8016ad000)
        libgrass_linkm.7.8.so => /usr/local/grass78/lib/libgrass_linkm.7.8.so (0x8018c6000)
        libgrass_rtree.7.8.so => /usr/local/grass78/lib/libgrass_rtree.7.8.so (0x801ac8000)
        libgrass_gis.7.8.so => /usr/local/grass78/lib/libgrass_gis.7.8.so (0x801cd2000)
        libgeos_c.so.1 => /usr/local/lib/libgeos_c.so.1 (0x80068d000)
        libgdal.so.3 => /usr/local/lib/libgdal.so.3 (0x802000000)
        libm.so.5 => /lib/libm.so.5 (0x800704000)
        libgrass_btree2.7.8.so => /usr/local/grass78/lib/libgrass_btree2.7.8.so (0x803254000)
        libgrass_gproj.7.8.so => /usr/local/grass78/lib/libgrass_gproj.7.8.so (0x803459000)
        libgrass_raster.7.8.so => /usr/local/grass78/lib/libgrass_raster.7.8.so (0x803667000)
        libpq.so.5 => /usr/local/lib/libpq.so.5 (0x800736000)
        libc.so.7 => /lib/libc.so.7 (0x80024a000)
        libgrass_datetime.7.8.so => /usr/local/grass78/lib/libgrass_datetime.7.8.so (0x803893000)
        libz.so.6 => /lib/libz.so.6 (0x800786000)
        libzstd.so.1 => /usr/local/lib/libzstd.so.1 (0x803a9b000)
        libintl.so.8 => /usr/local/lib/libintl.so.8 (0x8007c1000)
        libthr.so.3 => /lib/libthr.so.3 (0x8007ce000)
        libgeos-3.8.1.so => /usr/local/lib/libgeos-3.8.1.so (0x803b82000)
        libc++.so.1 => /usr/lib/libc++.so.1 (0x801f25000)
        libcxxrt.so.1 => /lib/libcxxrt.so.1 (0x803f69000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x803f8b000)
        libcrypto.so.111 => /lib/libcrypto.so.111 (0x803fa5000)
        libjson-c.so.4 => /usr/local/lib/libjson-c.so.4 (0x804296000)
        libodbc.so.2 => /usr/local/lib/libodbc.so.2 (0x8042a9000)
        libodbcinst.so.2 => /usr/local/lib/libodbcinst.so.2 (0x80431b000)
        libkmlbase.so.1 => /usr/local/lib/libkmlbase.so.1 (0x804336000)
        libkmldom.so.1 => /usr/local/lib/libkmldom.so.1 (0x804358000)
        libkmlengine.so.1 => /usr/local/lib/libkmlengine.so.1 (0x804400000)
        libkmlxsd.so.1 => /usr/local/lib/libkmlxsd.so.1 (0x804437000)
        libkmlregionator.so.1 => /usr/local/lib/libkmlregionator.so.1 (0x80444d000)
        libopenjp2.so.7 => /usr/local/lib/libopenjp2.so.7 (0x80445b000)
        libjasper.so.4 => /usr/local/lib/libjasper.so.4 (0x8044b7000)
        libhdf5.so.103 => /usr/local/lib/libhdf5.so.103 (0x804522000)
        libgif.so.7 => /usr/local/lib/libgif.so.7 (0x801ff5000)
        libjpeg.so.8 => /usr/local/lib/libjpeg.so.8 (0x8048bc000)
        libgeotiff.so.5 => /usr/local/lib/libgeotiff.so.5 (0x804954000)
        libtiff.so.5 => /usr/local/lib/libtiff.so.5 (0x80498c000)
        libpng16.so.16 => /usr/local/lib/libpng16.so.16 (0x804a0d000)
        libcfitsio.so.8 => /usr/local/lib/libcfitsio.so.8 (0x804a4c000)
        liblzma.so.5 => /usr/lib/liblzma.so.5 (0x804da6000)
        libproj.so.15 => /usr/local/lib/libproj.so.15 (0x804dd2000)
        librt.so.1 => /usr/lib/librt.so.1 (0x8050c4000)
        libdl.so.1 => /usr/lib/libdl.so.1 (0x8007fb000)
        libcurl.so.4 => /usr/local/lib/libcurl.so.4 (0x8050cc000)
        libxml2.so.2 => /usr/local/lib/libxml2.so.2 (0x805163000)
        libmysqlclient.so.20 => /usr/local/lib/mysql/libmysqlclient.so.20 (0x805400000)
        libexecinfo.so.1 => /usr/lib/libexecinfo.so.1 (0x8052fd000)
        libssl.so.111 => /usr/lib/libssl.so.111 (0x805302000)
        libexpat.so.1 => /usr/local/lib/libexpat.so.1 (0x80539b000)
        libminizip.so.1 => /usr/local/lib/libminizip.so.1 (0x8053c8000)
        liburiparser.so.1 => /usr/local/lib/liburiparser.so.1 (0x8053d7000)
        libkmlconvenience.so.1 => /usr/local/lib/libkmlconvenience.so.1 (0x8057bc000)
        libjbig.so.2 => /usr/local/lib/libjbig.so.2 (0x8057dd000)
        libsqlite3.so.0 => /usr/local/lib/libsqlite3.so.0 (0x8057ec000)
        libnghttp2.so.14 => /usr/local/lib/libnghttp2.so.14 (0x80598c000)
        libidn2.so.0 => /usr/local/lib/libidn2.so.0 (0x8059b9000)
        librtmp.so.1 => /usr/local/lib/librtmp.so.1 (0x8059dd000)
        libssh2.so.1 => /usr/local/lib/libssh2.so.1 (0x8059fe000)
        libheimntlm.so.11 => /usr/lib/libheimntlm.so.11 (0x8053f5000)
        libhx509.so.11 => /usr/lib/libhx509.so.11 (0x805a32000)
        libcom_err.so.5 => /usr/lib/libcom_err.so.5 (0x805a84000)
        libasn1.so.11 => /usr/lib/libasn1.so.11 (0x805a89000)
        libwind.so.11 => /usr/lib/libwind.so.11 (0x805b2f000)
        libheimbase.so.11 => /usr/lib/libheimbase.so.11 (0x805b59000)
        libroken.so.11 => /usr/lib/libroken.so.11 (0x805b60000)
        libcrypt.so.5 => /lib/libcrypt.so.5 (0x805b76000)
        libkrb5.so.11 => /usr/lib/libkrb5.so.11 (0x805b97000)
        libgssapi.so.10 => /usr/lib/libgssapi.so.10 (0x805c1a000)
        libgssapi_krb5.so.10 => /usr/lib/libgssapi_krb5.so.10 (0x805c27000)
        libelf.so.2 => /lib/libelf.so.2 (0x805c49000)
        libunistring.so.2 => /usr/local/lib/libunistring.so.2 (0x805c64000)
        libprivateheimipcc.so.11 => /usr/lib/libprivateheimipcc.so.11 (0x805e1f000)
[0]# 

-- Martin
Comment 12 Martin Birgmeier 2020-04-21 19:21:02 UTC
Created attachment 213648 [details]
listing of installed ports + 3 logs of portmaster runs

O.k. here are results... and they are strange. The files referenced below are part of the portmaster-logs.tgz uploaded with this comment.

1. Updated the ports tree to r532281.
2. Ran portmaster. This resulted in the ports listed in "installed-ports".
3. Applied the patches from comment #9.
4. Ran portmaster on grass7-7.8.2. This succeeded. But the log file "portmaster.grass7-7.8.2.2020-04-21.20:37:37" shows mind-boggling errors which do not lead to an abort of the build!
5. Deinstalled the newly installed grass7-7.8.2_1 and reverted to my old grass7-7.8.2 (built and packaged a while ago using the "just build it twice" method I described in comment #6).
6. Undid your changes and again ran portmaster on grass7-7.8.2. Against expectations this succeeded! However again with huge errors in the log file "portmaster.grass7-7.8.2.2020-04-21.20:45:42" which do not abort the build!
7. Did not believe that it succeeded. Deinstalled the newly installed grass7-7.8.2 and reverted to the same version but using my old package.
8. Still without your changes, again ran portmaster on grass7-7.8.2 (so, the same setup as for 6.). It succeeded again, again with gross errors in "portmaster.grass7-7.8.2.2020-04-21.20:54:05".

So... currently it works with or withour your change from comment #9, but in either case with wild errors during the build which nonetheless do not let the build fail.

To me this looks like a mixup of include files between native, llvm port, and gcc9 installations. Maybe it is currently succeeding because both gcc9 and llvm have recently been updated:

Mar 26 19:31:55 v904 pkg-static[14313]: gcc9-9.2.0_1 deinstalled
Mar 26 19:32:08 v904 pkg-static[14491]: gcc9-9.3.0 installed

Apr 16 14:43:28 v904 pkg-static[95288]: llvm90-9.0.1 deinstalled
Apr 16 14:44:34 v904 pkg-static[95473]: llvm90-9.0.1_1 installed

I hope all of this helps you in finding out what is going on here.

-- Martin
Comment 13 Loïc Bartoletti freebsd_committer 2020-06-03 19:09:32 UTC
I never reproduced this issue. I'm really sorry. I'm updating grass to 7.8.3 I hope this issue will be solved.
Comment 14 Martin Birgmeier 2020-06-08 17:13:54 UTC
Dear Loïc,

Thank you for all your efforts.

I now did a build from a system with only a few ports installed using "portmaster databases/grass7". And indeed this succeeded without the errors I described.

So I guess it must be some interaction with one of the additional ports I usually have installed. Should I ever find out which one I'll add to this PR, but for the time being let us close it.

Best regards,

Martin