Bug 243581 - print/pecl-pdflib: Fails to build: PDFlib needs confirmation, but BATCH is defined
Summary: print/pecl-pdflib: Fails to build: PDFlib needs confirmation, but BATCH is de...
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alex Dupre
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2020-01-25 04:44 UTC by Tommy P
Modified: 2020-01-25 07:53 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (ale)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tommy P 2020-01-25 04:44:10 UTC
I'm unable to build print/pecl-pdflib:

root@12amd64v1-default-min:/usr/ports/print/pecl-pdflib # make
===>  php74-pecl-pdflib-4.1.4_1 License PDFlib needs confirmation, but BATCH
is defined.
*** Error code 1

Stop.
make: stopped in /usr/ports/print/pecl-pdflib

uname -a
FreeBSD 12amd64v1-default-min 12.1-RELEASE-p1 FreeBSD 12.1-RELEASE-p1 #0 r356769M: Wed Jan 15 19:43:27 PST 2020

Please advise.  TIA!
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2020-01-25 04:50:59 UTC
Added in ports r520427 corrected in ports r520448, reported by Tobias (cc'd)

This (not allowing BATCH building) appears to be intended.
Comment 2 Tobias Kortkamp freebsd_committer 2020-01-25 05:07:29 UTC
Add LICENSES_ACCEPTED=PDFlib to your make.conf