Bug 243629 - www/firefox: crashs on start up
Summary: www/firefox: crashs on start up
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-gecko mailing list
URL:
Keywords:
: 243639 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-26 21:05 UTC by aryeh.friedman
Modified: 2020-03-16 05:07 UTC (History)
8 users (show)

See Also:
w.schwarzenfeld: maintainer-feedback? (gecko)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aryeh.friedman 2020-01-26 21:05:26 UTC
When attempting to start firefox (similar output if --first-startup and --safe-mode options are used:

aryehl@neomarx:/home/aryehl/Desktop% firefox 

(firefox:1519): GVFS-RemoteVolumeMonitor-WARNING **: 16:02:34.431: remote volume monitor with dbus name org.gtk.vfs.HalVolumeMonitor is not supported
Exiting due to channel error.
Segmentation fault (core dumped)

Note: A window frame starts to render right before the seg fault

This behavior only started after updating the port to 72.0.2_1_1 from whatever version came right before it (I do portmaster -ad every day but forget the last version of firefox)
Comment 1 aryeh.friedman 2020-01-26 21:06:39 UTC
(In reply to aryeh.friedman from comment #0)
Forgot to mention I erased my profile also to no avail.
Comment 2 aryeh.friedman 2020-01-26 23:18:30 UTC
Reverting to r523377 does not fix the issue despite it not being an issue with r523377 before upgrading to r524143
Comment 3 david 2020-01-27 00:07:38 UTC
I had seen some similar symptoms (ref. http://docs.FreeBSD.org/cgi/mid.cgi?20200126165149.GV1292); per Michael Butler's note (http://docs.FreeBSD.org/cgi/mid.cgi?3cc891ac-b7a2-6046-1ff8-49d68fd57637), this seems to be caused by the update of databases/sqlite3 from sqlite3-3.30.1 to sqlite3-3.31.0.

I tried reverting databases/sqlite3 to sqlite3-3.30.1, and (as Michael indicated), www/firefox now works for me.
Comment 4 Tomoaki AOKI 2020-01-27 00:17:52 UTC
What's your databases/sqlite3 version?
If 3.31.0, try downgrading to previous 3.30.1 would help.

I've caught error below just after upgrading databases/sqlite3,
and rolling back databases/sqlite3 to r524161 fixes the issue.

=== Error below: ===

1580080903428	addons.webextension.{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}	WARN	Loading extension '{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}': Reading manifest: Warning processing storage: An unexpected property was found in the WebExtension manifest.
Exiting due to channel error.
Exiting due to channel error.

[1]  + segmentation fault (core dumped)  firefox

=== Error abobe: ===

Extension ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} is Adblock Plus,
but I suspect SQLite database access on loading extension.

I google'd and found that Debian people are also affected. [[1]]
So this should NOT be FreeBSD-specific.


CC'ing databases/sqlite3 maintainer to request reverting r524162
until firefox is fixed for this.


[[1]] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=949644
Comment 5 Walter Schwarzenfeld freebsd_triage 2020-01-27 09:07:34 UTC
Sqlite3 reverted to 3.30.1 with ports r524241.
Comment 6 Jan Beich freebsd_committer 2020-01-27 16:46:22 UTC
*** Bug 243639 has been marked as a duplicate of this bug. ***
Comment 7 Jan Beich freebsd_committer 2020-01-27 16:59:24 UTC
Upstream proposed https://www.sqlite.org/src/info/34ab760689fd493e which may end up in the next SQLite release.
Comment 8 aryeh.friedman 2020-01-27 17:28:15 UTC
As the OP I just want to confirm reverting sqlite3 does in fact fix the original problem in both versions of FF I reported it in.
Comment 9 Zane C. Bowers-Hadley 2020-02-02 15:46:54 UTC
This happens for me regardless of the version of sqlite3 used. Rebuilding firefox post updating sqlite3 also does nothing.

Firefox 72 consistently does this for me. Only fix I've found is reverting www/firefox to r521037.
Comment 10 Patrick McMunn 2020-03-16 00:36:38 UTC
I've also encountered this problem with firefox-74.0_3,1 on FreeBSD 12.1-RELEASE-p2 under Plasma 5. For the time being, I've switched to Firefox ESR which works fine. But the problem is still present with the current Firefox.
Comment 11 david 2020-03-16 02:20:34 UTC
No further issues for me, since databases/sqlite3 updated to sqlite3-3.30.1_1,1.  (Delayed response; sorry.)  Now running firefox-74.0_5,1 to type this; FreeBSD is:
FreeBSD g1-55.catwhisker.org 12.1-STABLE FreeBSD 12.1-STABLE #635 r359003M/359007: Sun Mar 15 03:41:36 PDT 2020     root@g1-55.catwhisker.org:/common/S1/obj/usr/src/amd64.amd64/sys/CANARY  amd64
Comment 12 Zane C. Bowers-Hadley 2020-03-16 03:08:08 UTC
(In reply to david from comment #11)

Still failing for me even with updated here.
Comment 13 Jan Beich freebsd_committer 2020-03-16 04:36:01 UTC
firefox 74 no longer uses databases/sqlite3 because it's too old and 75 removed the support. sqlite3 3.31 issue affected *both* www/firefox and www/firefox-esr, so it was fixed upstream in firefox 73.0/68.5esr as well as sqlite 3.31.1.

Closing. This bug is not a dumping ground for random crash reports.
Comment 14 Jan Beich freebsd_committer 2020-03-16 05:07:51 UTC
(In reply to Zane C. Bowers-Hadley from comment #9)
> Firefox 72 consistently does this for me. Only fix I've found is
> reverting www/firefox to r521037.

Could be bug 243252. Bisect otherwise then file a separate bug. The range between r521037 and now is too big to reason about.

(In reply to Patrick McMunn from comment #10)
> I've also encountered this problem with firefox-74.0_3,1
> on FreeBSD 12.1-RELEASE-p2 under Plasma 5.

File a separate bug, documenting the error message on console, crash backtrace and the last working revision.