Bug 243639 - www/firefox - crashes on latest version after upgrade
Summary: www/firefox - crashes on latest version after upgrade
Status: Closed DUPLICATE of bug 243629
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-gecko mailing list
URL: https://hg.mozilla.org/try/rev/8d7104...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-27 00:39 UTC by andy
Modified: 2020-01-27 16:59 UTC (History)
3 users (show)

See Also:
w.schwarzenfeld: maintainer-feedback? (gecko)


Attachments
stacktrace (2.13 KB, text/plain)
2020-01-27 01:19 UTC, Craig Leres
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description andy 2020-01-27 00:39:54 UTC
FreeBSD FreeBSD_13 13.0-CURRENT FreeBSD 13.0-CURRENT #6 r357147: Sun Jan 26 12:33:05 EST 2020     root@FreeBSD_13:/usr/obj/usr/src/amd64.amd64/sys/MYKERNEL  amd64 1300076

Firefox is broken for me.

https://sebsauvage.net/paste/?e6740964c9064629#B7dYVum0grsYfcbfkEuIE4HNuaurWArLPfvRqmzH2Ws=

# truss firefox
mmap(0x0,135168,PROT_READ|PROT_WRITE,MAP_PRIVATE|MAP_ANON,-1,0x0) = 34377129984 (0x801096000)
issetugid()					 = 0 (0x0)
open("/etc/libmap.conf",O_RDONLY|O_CLOEXEC,0102310030) = 3 (0x3)
fstat(3,{ mode=-rw-r--r-- ,inode=41974292,size=115,blksize=32768 }) = 0 (0x0)
read(3,"# $FreeBSD: head/libexec/rtld-el"...,115) = 115 (0x73)
close(3)					 = 0 (0x0)
open("/usr/local/etc/libmap.d",O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC,0165) = 3 (0x3)
fcntl(3,F_ISUNIONSTACK,0x0)			 = 0 (0x0)
getdirentries(3,"\M-%\M-vP\^B\0\0\0\0\f\0\0\0\0\0"...,4096,{ 0x0 }) = 104 (0x68)
open("/usr/local/etc/libmap.d/nvidia.conf",O_RDONLY|O_CLOEXEC,0165) = 4 (0x4)
fstat(4,{ mode=-rw-r--r-- ,inode=38860496,size=234,blksize=32768 }) = 0 (0x0)
read(4,"# libmap.conf file for nvidia pr"...,234) = 234 (0xea)
close(4)					 = 0 (0x0)
getdirentries(3,0x80109b008,4096,{ 0x200 })	 = 0 (0x0)
close(3)					 = 0 (0x0)
open("/var/run/ld-elf.so.hints",O_RDONLY|O_CLOEXEC,0100470601) = 3 (0x3)
read(3,"Ehnt\^A\0\0\0\M^@\0\0\0/\^A\0\0"...,128) = 128 (0x80)
fstat(3,{ mode=-r--r--r-- ,inode=16774997,size=431,blksize=32768 }) = 0 (0x0)
pread(3,"/lib:/usr/lib:/usr/lib/compat:/u"...,303,0x80) = 303 (0x12f)
close(3)					 = 0 (0x0)
open("/lib/libc++.so.1",O_RDONLY|O_CLOEXEC|O_VERIFY,00) ERR#2 'No such file or directory'
...
fstat(46,{ mode=-rw-r--r-- ,inode=31541148,size=32768,blksize=32768 }) = 0 (0x0)
_umtx_op(0x80c6e81e8,UMTX_OP_WAIT_UINT_PRIVATE,0x0,0x18,0x7fffde9d0bf8) ERR#60 'Operation timed out'
mmap(0x0,45056,PROT_READ|PROT_WRITE,MAP_PRIVATE|MAP_ANON|MAP_ALIGNED(12),-1,0x0) = 34857398272 (0x81da9b000)
_umtx_op(0x7fffde9d09a0,UMTX_OP_NWAKE_PRIVATE,0x1,0x0,0x0) = 0 (0x0)
_umtx_op(0x80c6e8200,UMTX_OP_WAIT_UINT_PRIVATE,0x0,0x0,0x0) = 0 (0x0)
lseek(46,0x0,SEEK_SET)				 = 0 (0x0)
read(46,"SQLite format 3\0\M^@\0\^B\^B\0@"...,32768) = 32768 (0x8000)
SIGNAL 11 (SIGSEGV) code=SEGV_ACCERR trapno=12 addr=0x81ccb9fff
sigprocmask(SIG_SETMASK,{ },0x0)		 = 0 (0x0)
unlink("/root/.mozilla/firefox/rwylrgv0.default-release/lock") = 0 (0x0)
close(9)					 = 0 (0x0)
sigprocmask(SIG_SETMASK,{ SIGHUP|SIGINT|SIGQUIT|SIGILL|SIGTRAP|SIGABRT|SIGEMT|SIGFPE|SIGKILL|SIGBUS|SIGSEGV|SIGSYS|SIGPIPE|SIGALRM|SIGTERM|SIGURG|SIGSTOP|SIGTSTP|SIGCONT|SIGCHLD|SIGTTIN|SIGTTOU|SIGIO|SIGXCPU|SIGXFSZ|SIGVTALRM|SIGPROF|SIGWINCH|SIGINFO|SIGUSR1|SIGUSR2 },{ }) = 0 (0x0)
sigaction(SIGSEGV,{ SIG_DFL SA_RESTART ss_t },{ 0x801205820 SA_ONSTACK|SA_SIGINFO ss_t }) = 0 (0x0)
sigprocmask(SIG_SETMASK,{ },0x0)		 = 0 (0x0)
sigprocmask(SIG_UNBLOCK,{ SIGSEGV },0x0)	 = 0 (0x0)
thr_self(0x7fffffff2740)			 = 0 (0x0)
thr_kill(101362,SIGSEGV)			 = 0 (0x0)
SIGNAL 11 (SIGSEGV) code=SI_LWP pid=53676 uid=0
_umtx_op(0x80c6e8110,UMTX_OP_WAIT_UINT_PRIVATE,0x0,0x0,0x0) ERR#4 'Interrupted system call'
<thread 100578 exited>
<thread 100689 exited>
<thread 100731 exited>
<thread 100768 exited>
<thread 100707 exited>
<thread 100763 exited>
<thread 100620 exited>
<thread 100716 exited>
<thread 100826 exited>
<thread 100804 exited>
<thread 101077 exited>
<thread 100705 exited>
<thread 100801 exited>
<thread 101231 exited>
<thread 100745 exited>
<thread 101287 exited>
<thread 100690 exited>
<thread 100752 exited>
<thread 100772 exited>
<thread 101489 exited>
<thread 100777 exited>
<thread 101316 exited>
<thread 101734 exited>
<thread 101230 exited>
<thread 101492 exited>
<thread 101324 exited>
<thread 101234 exited>
<thread 101733 exited>
<thread 101225 exited>
<thread 101296 exited>
<thread 101732 exited>
<thread 101228 exited>
<thread 101339 exited>
<thread 101254 exited>
<thread 101320 exited>
<thread 101256 exited>
<thread 100780 exited>
<thread 101238 exited>
<thread 101233 exited>
<thread 100665 exited>
<thread 100698 exited>
<thread 100195 exited>
<thread 100699 exited>
<thread 101735 exited>
Exiting due to channel error.
process killed, signal = 11 (core dumped)


# firefox
Exiting due to channel error.
Segmentation fault (core dumped)
Comment 1 Craig Leres freebsd_committer 2020-01-27 01:19:54 UTC
Created attachment 211090 [details]
stacktrace

In my case both firefox and thunderbird were borked.

First I tried reinstalling all packages. Next, seeing sqlite3 in the stacktrace (attached) I tried downgrading databases/sqlite3 to 3.30.1 (r516357) which fixed both.
Comment 2 andy 2020-01-27 01:41:02 UTC
Hi Craig:

Would please post the exact commands/procedure you used to downgrade sqlite3 to 3.30.1 (r516357).  I would like to try it.  Thank you.
Comment 3 Craig Leres freebsd_committer 2020-01-27 01:44:34 UTC
(In reply to andy from comment #2)
svn up -r516357 /usr/local/poudriere/ports/current-patched/databases/sqlite3
poudriere bulk -C -j 11release -p current databases/sqlite3
Comment 4 andy 2020-01-27 01:56:08 UTC
I think Craig is right, I just did pkg delete -f sql and then pkg install sql.  I now have sqlite3-3.30.1 installed and Firefox starts successfully.
Comment 5 Walter Schwarzenfeld freebsd_triage 2020-01-27 09:05:43 UTC
Sqlite3 reverted to 3.30.1 with r524241.
Comment 6 Walter Schwarzenfeld freebsd_triage 2020-01-27 09:06:26 UTC
Correct: ports rr524241.
Comment 7 Jan Beich freebsd_committer 2020-01-27 16:46:22 UTC
Let's discuss possible fixes in one place.

*** This bug has been marked as a duplicate of bug 243629 ***