Bug 243674 - graphics/vips: Update to 8.9.1
Summary: graphics/vips: Update to 8.9.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Danilo Egea Gondolfo
URL: https://github.com/libvips/libvips/bl...
Keywords: buildisok, needs-patch, needs-qa
: 243709 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-28 16:54 UTC by Greg Lewis
Modified: 2020-04-28 21:17 UTC (History)
2 users (show)

See Also:
contact: maintainer-feedback? (danilo)


Attachments
8.9.0 update (3.11 KB, patch)
2020-01-28 16:54 UTC, Greg Lewis
no flags Details | Diff
8.9.1 update (4.38 KB, patch)
2020-02-22 18:40 UTC, Greg Lewis
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Lewis freebsd_committer 2020-01-28 16:54:46 UTC
Created attachment 211134 [details]
8.9.0 update

Attached patch updates the port to 8.9.0

FWIW, you might consider using PORTDOCS=* in the Makefile rather than listing all the documentation in the packing list explicitly.
Comment 1 Automation User 2020-01-28 18:20:26 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/113015383
Comment 2 Evilham 2020-02-01 00:47:52 UTC
*** Bug 243709 has been marked as a duplicate of this bug. ***
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-11 09:19:22 UTC
Current pkg-descr WWW: URL points to http://jcupitt.github.io/libvips/ which is now 404
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2020-02-11 09:21:42 UTC
Also 8.9.1 was released 14 days ago
Comment 5 Greg Lewis freebsd_committer 2020-02-22 18:40:28 UTC
Created attachment 211841 [details]
8.9.1 update
Comment 6 Danilo Egea Gondolfo freebsd_committer 2020-02-23 20:26:24 UTC
Your patch looks good. Thank you.

I accidentally found out that one of the consumers of this port, graphics/photoflow, is crashing with this version when you click on the button "basic adjustments". I'm looking at it.
Comment 7 Danilo Egea Gondolfo freebsd_committer 2020-02-23 21:02:02 UTC
For reference, here is the stack trace https://gist.github.com/daniloegea/92499850d1ff47e4959ce75120dca647
Comment 8 Danilo Egea Gondolfo freebsd_committer 2020-02-23 21:27:59 UTC
The crash I mentioned doesn't happen with vips 8.9.0. I suspect it's related to this commit: https://github.com/libvips/libvips/commit/fda5e5c402b1cb57dda010d21c656e6f9d8d1544


Although, a new crash happens when I try to close photoflow without saving the changes: https://gist.github.com/daniloegea/083a8ecf2f0ada3c28e7ff58fb3a27ca
Comment 9 commit-hook freebsd_committer 2020-04-28 21:14:52 UTC
A commit references this bug:

Author: danilo
Date: Tue Apr 28 21:14:29 UTC 2020
New revision: 533272
URL: https://svnweb.freebsd.org/changeset/ports/533272

Log:
  - Update graphics/vips to 8.9.2
  - Add DEBUG option
  - Update WWW

  PR:		243674

Changes:
  head/graphics/nip2/Makefile
  head/graphics/pecl-vips/Makefile
  head/graphics/photoflow/Makefile
  head/graphics/rubygem-ruby-vips/Makefile
  head/graphics/vips/Makefile
  head/graphics/vips/distinfo
  head/graphics/vips/pkg-descr
  head/graphics/vips/pkg-plist
Comment 10 Danilo Egea Gondolfo freebsd_committer 2020-04-28 21:17:12 UTC
Updated to 8.9.2. Thanks!