Bug 243695 - bad checksums cause bsdinstall to fail (11.3-RELEASE)
Summary: bad checksums cause bsdinstall to fail (11.3-RELEASE)
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.3-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-29 05:16 UTC by Adrian Waters
Modified: 2020-02-03 02:33 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Waters 2020-01-29 05:16:08 UTC
I've a need to install a test instance of FreeBSD 11.30-RELEASE amd64, but so far attempts to install with bsdinstall are failing due to incorrect checksums.

The dvd1 ISO reports incorrect checksum for kernel.txz, while the disc1 ISO reports it for base.txz.
Comment 1 Adrian Waters 2020-01-29 05:20:04 UTC
I should note in case this is relevant that I'm attempting to install into a Virtualbox (6.0.14) VM.
Comment 2 Adrian Waters 2020-02-03 02:33:42 UTC
After a very frustrating couple of days I'm going to mark this as closed, as I don't believe the problem is with the ISOs.

It appears to be an issue with multiple 6.0 and 6.1 versions of Virtualbox on two of my MacBook Pros running Mojave 10.14.6.  They are continually throwing bus errors and segfaults, even for old VMs that were working fine previously, including a RHEL vagrant box that I built last December.

Essentially I think this bud that I logged is caused by distextract crashing out with a bus error (signal 10).  The crash is appears to be random, which explains why different ISOs had the error on different txz files. I've also experienced freebsd-update failing to work because of (I believe) bus errors causing stat to crash and this being registered as files having changed during update, and also my old FreeBSD VM having issues keeping things like unbound, nsd, slapd, sshd and various others in a running state.  Lots of SSL errors too.

I've got no idea where to go from here, but as I no longer believe this is a problem with the ISOs I am closing this bug.